Bug 435523 - Should not display WPA access points for cards w/o WPA support
Should not display WPA access points for cards w/o WPA support
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: NetworkManager (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Dan Williams
desktop-bugs@redhat.com
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-29 16:35 EST by Suzanne Hillman
Modified: 2013-02-15 17:29 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-15 17:29:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Suzanne Hillman 2008-02-29 16:35:53 EST
Description of problem:
Should not display WPA access points for cards w/o WPA support.
Comment 1 Dan Williams 2008-09-24 06:27:16 EDT
ran into this the other day on airo cards... unfortunately we need minimal WPA Information Element support in the driver to be able to do this, which does not imply actual WPA connection support.  RHEL5 airo driver has this capability if the card's firmware is new enough, but other drivers like prism54 or orinoco won't be able to handle this.
Comment 2 Dan Williams 2009-11-12 16:24:18 EST
We could blacklist airo card as not supporting WPA in NM, but I'd like to punt this until we get a customer request for something like it.
Comment 3 Suzanne Hillman 2009-11-13 11:21:01 EST
Punting works for me.
Comment 6 Dan Williams 2013-02-15 17:29:39 EST
NM in RHEL6 grabs the WPA capabilities from the card, so it won't show any access points that don't match the card's capabilities, *as long as* the driver correctly returns access points with all beacon Information Elements intact.

eg, if the driver sees an AP in the scan list that is actually WPA-capable, but the card/driver can't handle WPA and thus only reports the AP as WEP-capable, that's a card/driver issue and we don't really want to solve that in NM.  Should be fixed in the driver instead.

Note You need to log in before you can comment on or make changes to this bug.