Bug 435525 - tg-admin i18n compile fails
tg-admin i18n compile fails
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: TurboGears (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-29 17:33 EST by Rob Crittenden
Modified: 2016-09-19 22:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-01 10:35:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob Crittenden 2008-02-29 17:33:56 EST
Description of problem:

TurboGears is out-of-sync with python-paste-script. In building a package (ipa)
which provides i18n pages I see this:

tg-admin i18n compile
Traceback (most recent call last):
  File "/usr/bin/tg-admin", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 2565, in <module>
    parse_requirements(__requires__), Environment()
  File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 524, in resolve
    raise DistributionNotFound(req)  # XXX put more info here
pkg_resources.DistributionNotFound: PasteScript>=0.9.7,<1.6

The current version of python-paste-script in rawhide is 1.6.2, hence the failure.

Version-Release number of selected component (if applicable):

TurboGears-1.0.4.3-2.fc9.noarch
python-paste-script-1.6.2-1.fc9.noarch
ipa-0_99-11_fc9

Full logs in koji task http://koji.fedoraproject.org/koji/taskinfo?taskID=480079
Comment 1 Toshio Ernie Kuratomi 2008-02-29 17:57:23 EST
Before reverting python-paste-script we should probably look at what went into
this TurboGears upstream comment::
  http://trac.turbogears.org/changeset/4152

The changeLog sounds like paste-script < 1.6 or > 1.6.2 will be okay.
Comment 2 Toshio Ernie Kuratomi 2008-02-29 17:58:12 EST
Make that, >= 1.6.2.  if so we should change the Turbogears requirement.
Comment 3 Luke Macken 2008-02-29 22:01:57 EST
Thanks for looking into this, Toshio.  I'll kick out a new TurboGears build with
this requirement.
Comment 4 Luke Macken 2008-02-29 23:12:44 EST
TurboGears-1.0.4.3-3.fc9 built in devel.  

Rob, could you please try rebuilding and see if the problem is fixed?
Comment 5 Rob Crittenden 2008-03-01 00:41:42 EST
ipa builds now, http://koji.fedoraproject.org/koji/taskinfo?taskID=481163

Note You need to log in before you can comment on or make changes to this bug.