Bug 435536 - fetchmail emits pointless message on stderr
fetchmail emits pointless message on stderr
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: fetchmail (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-01 02:56 EST by JW
Modified: 2008-06-27 05:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-27 05:01:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description JW 2008-03-01 02:56:56 EST
Description of problem:
If fetchmail is run as root then it emits the message "WARNING: Running as root
is discouraged."

Version-Release number of selected component (if applicable):
fetchmail-6.3.8-3

How reproducible:
Always

Steps to Reproduce:
1. run fetchmail as root
  
Actual results:
Emits "WARNING: Running as root is discouraged." on stderr

Expected results:
Should not emit pointless nanny messages.

Additional info:
Messages on stderr should be reserved for indications of serious problems.  The
above message is not the result of a serious problem (it is merely one person's
idea of a possible problem perhaps under certain largely improbable circumstances).

If programs emit silly gratuitous messages on stderr then users are likely to
start redirecting stderr to /dev/null and as a result will miss the real useful
error messages for which stderr is specifically reserved.

For goodness sake ... will we start seeing "bash" start emitting such pointless
messages? Because running "bash" with redirection as root is also possibly not
recommended because one could accidentally clobber a file.  So is using "rm -fr"
and so on, and ad infinitum, and ad absurditum.
Comment 1 Vitezslav Crhonek 2008-06-27 05:01:33 EDT
Hi,

This warning is legitimate in my point of view and I will not differentiate from
upstream code.

Feel free to discuss your ideas at fetchmail-users@lists.berlios.de or at
fetchmail-devel@lists.berlios.de.
Comment 2 JW 2008-06-27 05:48:02 EDT
Maybe all programs should emit an error message "WARNING: In all likelihood a
dickhead is running this program" on stderr.  That is what stderr is for - isn't
it? To tell people the obvious?  To provide a serious error message that
indicates a serious problem.

Maybe bash could do likewise: "WARNING: Running as root is discouraged."

Thanks, Vitezslav, for so effectively communicating your ability to rationalize.


Note You need to log in before you can comment on or make changes to this bug.