Bug 435544 - inefficient log parser: kerneloops uses lots of CPU time with large log files
inefficient log parser: kerneloops uses lots of CPU time with large log files
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kerneloops (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 436127 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-01 07:28 EST by Pierre Ossman
Modified: 2011-12-14 02:34 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-17 13:24:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pierre Ossman 2008-03-01 07:28:15 EST
The parser in kerneloops is annoyingly ineffecient. When messages starts to grow
a bit (mine is around 6 MB), kerneloops eats 100% CPU for a few minutes on a
brand new CPU.

I gdb:d the thing a bit, and it is spending all of its time in strstr(), which
is why I believe it's the log file parsing that's the culprit. Is it doing a
strstr() on the entire buffer for each thing it is looking for? :)
Comment 1 Chuck Ebbert 2008-03-05 17:39:36 EST
*** Bug 436127 has been marked as a duplicate of this bug. ***
Comment 2 Chuck Ebbert 2008-03-17 13:24:55 EDT
Fixed in 0.10-7

Note You need to log in before you can comment on or make changes to this bug.