This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 435554 - netstat -s does not show TcpExt
netstat -s does not show TcpExt
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: net-tools (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Radek Vokal
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 493314
  Show dependency treegraph
 
Reported: 2008-03-01 10:50 EST by Sami Farin
Modified: 2009-04-01 07:53 EDT (History)
0 users

See Also:
Fixed In Version: 1.60-87
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 493314 (view as bug list)
Environment:
Last Closed: 2008-03-04 10:40:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
double fgets buffer size (446 bytes, patch)
2008-03-01 10:50 EST, Sami Farin
no flags Details | Diff

  None (edit)
Description Sami Farin 2008-03-01 10:50:09 EST
Description of problem:
because of silly fixed length buffer of 1024 bytes in statistics.c:process_fd(),
netstat -s fails with
"error parsing /proc/net/netstat: Success"

Version-Release number of selected component (if applicable):
1.60-86

How reproducible:
depends on kernel, 2.6.23 works, 2.6.24.3 does not work.

Steps to Reproduce:
1. netstat -s
2.
3.
  
Actual results:
parsing fails

Expected results:
show TcpExt stats

Additional info:
Comment 1 Sami Farin 2008-03-01 10:50:09 EST
Created attachment 296453 [details]
double fgets buffer size
Comment 2 Radek Vokal 2008-03-04 10:40:39 EST
Patch applied on rawhide

Note You need to log in before you can comment on or make changes to this bug.