Bug 435575 - keycode mapping doesn't match what is written on keyboard
keycode mapping doesn't match what is written on keyboard
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kbd (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-01 19:27 EST by JW
Modified: 2008-03-04 03:57 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-04 03:57:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description JW 2008-03-01 19:27:49 EST
Description of problem:
The US key mapping for keycode 14 is set to Delete when in actual fact all
keyboards have "Backspace" written on the key which emits keycode 14.
Also, there is no mapping for keycode 111 (Delete).

Version-Release number of selected component (if applicable):
kbd-1.12-27

How reproducible:
Always

Steps to Reproduce:
1. Read /lib/kbd/keymaps/i386/qwerty/us.map.gz
2. Check the keycode that key labelled Backspace on your keyboard emits.
  
Actual results:
1. keycode 14 Delete
2. Backspace emits keycode 14

Expected results:
1. keycode 14 Backspace
2. Backspace emits keycode 14

Additional info:
There should also be an entry "keycode 111 Delete".
Comment 1 Vitezslav Crhonek 2008-03-03 09:03:55 EST
Hi,

thanks for report.

This is not a bug - keycodes correspond to the default keymap built into the kernel.

See http://tldp.org/HOWTO/Keyboard-and-Console-HOWTO-5.html for more informations.
Comment 2 JW 2008-03-03 09:13:53 EST
(In reply to comment #1)
> Hi,
> 
> thanks for report.
> 
> This is not a bug - keycodes correspond to the default keymap built into the
kernel.
> 
> See http://tldp.org/HOWTO/Keyboard-and-Console-HOWTO-5.html for more informations.

So how absurd is this quote from your reference:

"For example, suppose that you would like the Backspace key to send a BackSpace
(Ctrl-H, octal 010) and the grey Delete key a DEL (octal 0177) ..."

Gee, wouldn't it make sense for that to be the default?  Or would it be a more
sensible default to, say, have Backspace send a Delete and Delete send a Backspace?!

No wonder this planet is in a mess!


Comment 3 JW 2008-03-03 17:16:16 EST
The above link also states:

>> `Why doesn't the Backspace key generate BackSpace by default?'
>>
>> (i) Because the VT100 had a Delete key above the Enter key.
>>
>> (ii) Because Linus decided so. 

But clearly:

(i) is not the whole truth - see
http://www.cs.utk.edu/~shuford/terminal/vt100_keyboard.gif
(ii) Linus occasionally makes serious blunders

Pity nobody has the courage to contradict Linus.
Comment 4 Vitezslav Crhonek 2008-03-04 03:57:48 EST
Please do not reopen this bugzilla entry until default kernel keymap is changed.
Meanwhile it is not kbd bug.

Note You need to log in before you can comment on or make changes to this bug.