Bug 435577 - Entering 'ctrl-alt-del' before udev starts causes spewage and hang
Entering 'ctrl-alt-del' before udev starts causes spewage and hang
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: upstart (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Casey Dahlin
Fedora Extras Quality Assurance
:
: 435831 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-01 19:53 EST by Tom London
Modified: 2014-06-18 04:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-17 00:07:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch (1.36 KB, patch)
2008-03-12 13:14 EDT, Bill Nottingham
no flags Details | Diff

  None (edit)
Description Tom London 2008-03-01 19:53:03 EST
Description of problem:
If you enter 'ctrl-alt-delete' just before udev starts, you get lots of AVCs,
lots of red FAILED, some green SUCCEED messages, and a hang.

If you wait for the file systems to be mounted, appears to work as expected.

Version-Release number of selected component (if applicable):
upstart-0.3.9-5.fc9.i386

How reproducible:
Every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jóhann B. Guðmundsson 2008-03-07 03:25:03 EST
*** Bug 435831 has been marked as a duplicate of this bug. ***
Comment 2 Bill Nottingham 2008-03-12 12:20:06 EDT
OK, so what's happening here:

- control-alt-del is handled
- it calls shutdown
- shutdown switches it to runlevel 6
- as part of that, rcS is killed
- as a result of rcS being stopped, rc-default is *started*
- this switches to runlevel 3/5, cancelling the prior shutdown
- weirdness then happens
Comment 3 Casey Dahlin 2008-03-12 12:52:01 EDT
Makes sense.

We could solve with a lockfile.
Comment 4 Casey Dahlin 2008-03-12 12:53:06 EDT
Actually, we can't. Root is read-only at the time when we'd have to create the lock.
Comment 5 Bill Nottingham 2008-03-12 13:01:29 EDT
I think the simplest way to solve this may be to move rc-default into rcS (much
like it's in rcS-sulogin)
Comment 6 Bill Nottingham 2008-03-12 13:14:59 EDT
Created attachment 297806 [details]
patch

This patch moves the body of rc-default into rcS.
Comment 7 Bill Nottingham 2008-03-12 13:15:39 EDT
Not in this patch, but the default (in this and rcS-sulogin) should probably be
'3', not '2'.
Comment 8 Casey Dahlin 2008-03-17 00:07:01 EDT
Fixed in event-compat-sysv-0.3.9-10

Note You need to log in before you can comment on or make changes to this bug.