Bug 435608 - Missing dependency on python-libxml2
Missing dependency on python-libxml2
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: python-virtinst (Show other bugs)
5.1
All Linux
low Severity low
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
:
Depends On:
Blocks: 449772
  Show dependency treegraph
 
Reported: 2008-03-02 09:38 EST by Kamil Christ
Modified: 2009-12-14 16:18 EST (History)
2 users (show)

See Also:
Fixed In Version: 5.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-26 12:07:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kamil Christ 2008-03-02 09:38:30 EST
Description of problem:
Package python-virtinst is missing dependency on python-libxml2

Version-Release number of selected component (if applicable):
python-virtinst-0.103.0-3.el5_1.1

How reproducible:
Install minimal instalation with xen

Steps to Reproduce:
1. Prepare ks.cfg with %packages section like this:
%packages --nobase
-kudzu
xen

2. Install system based on this ks.cfg
3. Try to execute virt-install

Actual results:
# virt-install 
Traceback (most recent call last):
  File "/usr/sbin/virt-install", line 22, in ?
    import libxml2
ImportError: No module named libxml2

Expected results:
# virt-install 
What is the name of your virtual machine?

Additional info:
Another way to reproduce: 
# yum -y remove libxml2-python (this will not uninstall python-virtinst as 
should)
# virt-install
Comment 1 Ralph Angenendt 2008-03-02 10:10:43 EST
This is also http://bugs.centos.org/view.php?id=2723
Comment 2 Cole Robinson 2008-06-12 11:50:28 EDT
This is fixed upstream and is something we should pull in for 5.3.
Comment 3 RHEL Product and Program Management 2008-06-12 12:06:09 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Cole Robinson 2008-06-26 12:07:23 EDT
Whoops actually turns out this was fixed when we rebased in 5.2, so closing this
as CURRENTRELEASE. Sorry about the confusion.

Note You need to log in before you can comment on or make changes to this bug.