Bug 435624 - kernel ps3 updates-testings seems good wifi ps3 and look not gone
kernel ps3 updates-testings seems good wifi ps3 and look not gone
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
ppc64 Linux
low Severity urgent
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-02 13:37 EST by serge lacroute
Modified: 2008-07-10 13:33 EDT (History)
2 users (show)

See Also:
Fixed In Version: kernel-2.6.24.5-87.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-10 13:33:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages ps3 60gb (378.93 KB, text/plain)
2008-03-06 08:11 EST, serge lacroute
no flags Details

  None (edit)
Description serge lacroute 2008-03-02 13:37:35 EST
Description of problem:
	
Available in the kernel updates-testings
It comes with a patch for the ps3 wifi
	
On my ps3 60gb wifi does not seem to walk after a yum  --enablerepo=updates
testings -v upgrade kernel and reboot 
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 John W. Linville 2008-03-03 09:23:54 EST
What was your previous (working) kernel version?  Also, could you attach the 
contents of /var/log/messages after booting the non-working kernel?  Thanks!
Comment 2 serge lacroute 2008-03-06 08:09:36 EST
(In reply to comment #1)
> What was your previous (working) kernel version?  Also, could you attach the 
> contents of /var/log/messages after booting the non-working kernel?  Thanks!

	
I use the kernel 2.6.23.15-137.fc8.
Connection to the Internet is via the ethernet cable
the non-working kernel 2.6.24.3-12.fc8
The only WiFi only the onboard gelic b/g native interface for the wifi on the ps3
Comment 3 serge lacroute 2008-03-06 08:11:41 EST
Created attachment 297044 [details]
/var/log/messages ps3 60gb
Comment 4 John W. Linville 2008-03-06 08:57:24 EST
Well there seems to simply be no ps3 wireless driver in the F8 kernels.  Did 
it ever work with F8?

dwmw2, I thought we used to have gelic patches in F8?  Is this related to bug 
343901?

Serge, you may want to try a recent rawhide kernel.  Be advised that to do so 
will require updating mkinitrd from rawhide as well.
Comment 5 David Woodhouse 2008-03-06 09:03:53 EST
Yes, we used to have a gelic_wireless driver, and bug 343901 explains why we
turned it off. The _new_ driver presents the wireless as a separate device, and
should be fine. Getting that into F8 would be nice.
Comment 6 John W. Linville 2008-03-07 08:32:36 EST
I added the new gelic wireless driver to the kernels here:

   http://koji.fedoraproject.org/koji/taskinfo?taskID=497538

Unfortunately Koji thinks the build failed due to an internal error, but in 
fact the rpms are all available at the URL above.  Please give those (or some 
later F8 kernel) a try -- do they make the wireless work for you?
Comment 7 Kazunori Asayama 2008-03-12 02:45:23 EDT
(In reply to comment #6)
> I added the new gelic wireless driver to the kernels here:
> 
>    http://koji.fedoraproject.org/koji/taskinfo?taskID=497538
> 
> Unfortunately Koji thinks the build failed due to an internal error, but in 
> fact the rpms are all available at the URL above.  Please give those (or some 
> later F8 kernel) a try -- do they make the wireless work for you?

It works, though some care is needed as below.

* Your access point must allow 'ANY' connections.

* udev assigns an unexpected name 'eth1_renamed' to the wireless because PS3
  shares MAC address between the wireless and the ether.

  There is workaround for this problem.

  a. Remove /etc/udev/rules.d/70-persistent-net.rules and add the following
     rule to /etc/udev/rules.d/75-persistent-net-generator.rules:

DRIVERS=="ps3_gelic_driver", GOTO="persistent_net_generator_end"

  or,

  b. Replace contents of /etc/udev/rules.d/70-persistent-net.rules with
     the following two explicit rules:

SUBSYSTEM=="net", TEST!="wireless", ACTION=="add", DRIVERS=="?*",
ATTR{address}=="xx:xx:xx:xx:xx:xx", ATTR{type}=="1", NAME="eth0"

SUBSYSTEM=="net", TEST=="wireless", ACTION=="add", DRIVERS=="?*",
ATTR{address}=="xx:xx:xx:xx:xx:xx", ATTR{type}=="1", NAME="eth1"

     (the place holder xx:xx:xx:xx:xx:xx should be your MAC address)

I tried the following sequence:

[root@localhost ~]# iwconfig eth1 key xxxxxxxxxxxxxxxxxxxxxxxxxx
[root@localhost ~]# iwconfig eth1 essid yyyyyyyy
[root@localhost ~]# ifconfig eth1 inet nnn.nnn.nnn.nnn
Comment 8 serge lacroute 2008-05-02 04:55:51 EDT
I can not get the interface wifi
Yet I use the last bootloader otheros kboot consort
I use the kernel Koji
http://koji.fedoraproject.org/koji/buildinfo?buildID=47227

and i will not gone

I am near you to provide maximum information. that you want to know?

I bought my ps3 in france and I regularly updates Sony OS
Comment 9 John W. Linville 2008-05-02 08:46:51 EDT
It seems to be working for others, including me.  There is still the problem 
with the udev rules -- did you apply the technique described in comment 7?  
What is the exact nature of the problem you are seeing?  Could you attach the 
output of running 'iwconfig'?
Comment 10 David Woodhouse 2008-05-02 09:04:38 EDT
The problem with the udev rules should be fixed now. See bug #440568.

Note You need to log in before you can comment on or make changes to this bug.