Bug 43563 - XFree 4.0.3 crashes on my CSLU2 board (INTEL 815)
Summary: XFree 4.0.3 crashes on my CSLU2 board (INTEL 815)
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-05 15:33 UTC by Franz-J. Glandorf
Modified: 2007-04-18 16:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-12 18:49:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
result of startx >& Xlog (9.22 KB, patch)
2001-06-12 18:39 UTC, Franz-J. Glandorf
no flags Details | Diff
XF86Config-4 (1.82 KB, text/plain)
2001-06-12 18:40 UTC, Franz-J. Glandorf
no flags Details
/var/log/XFree86.0.log (19.79 KB, text/plain)
2001-06-12 18:42 UTC, Franz-J. Glandorf
no flags Details
/var/log/XFree86.9.log (20.54 KB, text/plain)
2001-06-12 18:44 UTC, Franz-J. Glandorf
no flags Details

Description Franz-J. Glandorf 2001-06-05 15:33:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.7 [de] (Win98; I)

Description of problem:
After I installed RedHat 7.1 at the first glance every thing with the X11 environment seemed to be OK. But after playing around and resizing 
some windows the desktop got more and more currupted. I downloaded XFree86-4.1.0, compiled it myself, and at least it seems to work better.

How reproducible:
Always

Steps to Reproduce:
1.Just start XFree with KDE or GNOME on a  box with a ASUS CSLU2 board
2.Open a window e.g. the Konquerer browser
3.Use the full screen button in the upper right corner of the window several times in a row
	

Actual Results:  First the dekoration of the window gets currupted and then the entire window gets scrambeld.
The complete X11 is unusable on this board.

Additional info:

Comment 1 Franz-J. Glandorf 2001-06-08 13:47:42 UTC
I have just discovered that XFree-4.1.0 does not work either. The symptoms are the same as under XFree-4.0.3 but
the erronous behavior  is not so reproducable. 


Comment 2 Mike A. Harris 2001-06-09 04:50:11 UTC
Using the official 4.0.3 release, please run:

Xconfigurator --preferxf4

Then please attach the resultant XF86Config-4 file that it generates,
as well as a copy of your XFree86 server log from after display corruption
or a crash.  Use the link below.

Comment 3 Mike A. Harris 2001-06-09 04:50:50 UTC
Misfiled against XFree86-Servers - changing.

Comment 4 Franz-J. Glandorf 2001-06-12 18:39:07 UTC
Created attachment 20883 [details]
result of startx >& Xlog

Comment 5 Franz-J. Glandorf 2001-06-12 18:40:35 UTC
Created attachment 20884 [details]
XF86Config-4

Comment 6 Franz-J. Glandorf 2001-06-12 18:42:26 UTC
Created attachment 20885 [details]
/var/log/XFree86.0.log

Comment 7 Franz-J. Glandorf 2001-06-12 18:44:16 UTC
Created attachment 20886 [details]
/var/log/XFree86.9.log

Comment 8 Franz-J. Glandorf 2001-06-12 18:49:55 UTC
Hello!
Sorry, I think I used the wrong link. Therefore all that again:

I reinstalled RedHat 7.1 from scratch and left evrything untouched. X keeps crashing.
I did what you asked for:
I run Xconfigurator --preferf4 and then startx >& Xlog.
The file Xlog and all Xfree86.log files I found as well as the XF86Config-4 file are attached to this mail.

Regards Franz-J.

Comment 9 Mike A. Harris 2002-03-16 15:37:00 UTC
Your log file clearly shows agpgart failing due to lack of memory
available.  This is not an XFree86 bug, just a misconfiguration of your
system CMOS likely.  You might want to try the xpert@xfree86.org
mailing list in case you need a hand with selecting the appropriate
CMOS configuration settings.

Hope this helps.


Note You need to log in before you can comment on or make changes to this bug.