Bug 435671 - can't export a PDF from lyx in rawhide
can't export a PDF from lyx in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lyx (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-03 04:03 EST by Alex Lancaster
Modified: 2008-03-07 03:03 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-07 03:03:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Lancaster 2008-03-03 04:03:03 EST
Description of problem:
Can't export PDF

Version-Release number of selected component (if applicable):
lyx-1.5.4-1.fc9.i386

How reproducible:
Always

Steps to Reproduce:
1. yum install lyx
2. reconfigure lyx to make sure
3. Help->Introduction
3. File->Export->PDF (pdflatex)
  
Actual results:
Copying /tmp/lyx_tmpdir22126iwMupD/lyx_tmpbuf0/Intro.pdf to [doc/Intro.pdf]
failed.

Expected results:
File should have been generated

Additional info:
Before the most recent texlive update, "View->PDF (pdflatex)" generated a PDF
that had the right number of pages, but all fonts were blank.  The latest
texlive update appeared to add a number of dependent packages.  Now at least the
PDF generates when viewing it.

Just for reference, this is the complete list of packages installed on fairly
bare machine when running:

sudo yum install lyx

  Installing: texlive-texmf-errata         ####################### [ 1/17] 
  Installing: texlive-texmf                ####################### [ 2/17] 
  Installing: texlive-texmf-errata-latex   ####################### [ 3/17] 
  Installing: texlive-texmf-latex          ####################### [ 4/17] 
  Installing: texlive-texmf-errata-fonts   ####################### [ 5/17] 
  Installing: texlive-texmf-errata-dvips   ####################### [ 6/17] 
  Installing: texlive-texmf-dvips          ####################### [ 7/17] 
  Installing: texlive-texmf-fonts          ####################### [ 8/17] 
  Installing: mathml-fonts                 ####################### [ 9/17] 
  Installing: texlive                      ####################### [10/17] 
  Installing: aiksaurus                    ####################### [11/17] 
  Installing: netpbm                       ####################### [12/17] 
  Installing: netpbm-progs                 ####################### [13/17] 
  Installing: psutils                      ####################### [14/17] 
  Installing: texlive-dvips                ####################### [15/17] 
  Installing: texlive-latex                ####################### [16/17] 
  Installing: lyx                          ####################### [17/17] 

I'm not sure if this is related but the latest "yum update" since the above
added the following tex-related packages:

Installed: tex-preview-11.85-7.fc9.noarch
Installed: texlive-utils-2007-21.fc9.i386
Comment 1 Rex Dieter 2008-03-04 10:26:23 EST
more than likely due to texlive flux atm, and the possibility that we're missing
the correct dep to pull in pdflatex (I *think* it lives in teslive-texmf-latex tho).
Comment 2 Alex Lancaster 2008-03-07 03:03:04 EST
(In reply to comment #1)
> more than likely due to texlive flux atm, and the possibility that we're missing
> the correct dep to pull in pdflatex (I *think* it lives in teslive-texmf-latex
tho).

Recent texlive updates have indeed appeared to fix this on the last I tested, so
closing. 

(By the way, the export issue was due to exporting a .lyx file that was in
write-only directory /usr/share/lyx/doc/ )

Note You need to log in before you can comment on or make changes to this bug.