Bug 435789 - /etc/profile.d/colorls.csh prints $LS_COLORS
/etc/profile.d/colorls.csh prints $LS_COLORS
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-03 16:52 EST by Peter Staubach
Modified: 2008-03-07 15:25 EST (History)
1 user (show)

See Also:
Fixed In Version: 6.9-15.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-07 14:52:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Staubach 2008-03-03 16:52:56 EST
Description of problem:

The script, /etc/profile.d/colorls.csh, prints the value of the shell
variable, LSCOLORS, if it is set already.

Version-Release number of selected component (if applicable):


How reproducible:

Always.

Steps to Reproduce:
1. cd /etc/profile.d
2. setenv LS_COLORS "*bug*"
3. csh /etc/profile.d/colorls.csh
  
Actual results:

You will see:

*bug*: No match

Expected results:

You should see no output at all.

Additional info:
Comment 1 Peter Staubach 2008-03-03 16:54:28 EST
The problem is that the test to check to see if the value of $LS_COLORS
on line 3 is not coded quite correct.  The $LS_COLORS should have double
quotes around to keep it from being expanded and attempting to match a
filename.
Comment 2 Ondrej Vasik 2008-03-04 09:10:17 EST
Thanks for report, fixed in coreutils-6.9-14.fc8 and coreutils-6.10-10.fc9
Comment 3 Fedora Update System 2008-03-04 09:12:17 EST
coreutils-6.9-14.fc8 has been submitted as an update for Fedora 8
Comment 4 Peter Staubach 2008-03-04 09:19:00 EST
Thanx for your quick handling!
Comment 5 Fedora Update System 2008-03-07 14:52:02 EST
coreutils-6.9-15.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Peter Staubach 2008-03-07 15:25:38 EST
Much better.  Thanx!

Note You need to log in before you can comment on or make changes to this bug.