Bug 435795 - Rich Sybase failover support
Rich Sybase failover support
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rgmanager (Show other bugs)
5.0
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Lon Hohberger
: ZStream
Depends On:
Blocks: 304931 435950 446541
  Show dependency treegraph
 
Reported: 2008-03-03 17:29 EST by Lon Hohberger
Modified: 2009-06-19 22:32 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 15:56:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sybase failover Resource Agent (13.88 KB, application/zip)
2008-03-04 10:08 EST, Rob Kenna
no flags Details
Sybase RA Doc (643.74 KB, application/zip)
2008-03-04 10:09 EST, Rob Kenna
no flags Details

  None (edit)
Description Lon Hohberger 2008-03-03 17:29:32 EST
+++ This bug was initially created as a clone of Bug #304931 +++

In conjunction with Sybase, build and certify a standard Sybase failover agent.
 This work is currently being carried out as joint development

-- Additional comment from kanderso@redhat.com on 2007-11-05 18:22 EST --
Removing the 5.2 flag, no work identified on our side as of yet.

-- Additional comment from rkenna@redhat.com on 2007-11-06 09:54 EST --
To be clear, Sybase has completed this work.  We simply need to integrate into
the release ad add Conga configuration support
Comment 1 Lon Hohberger 2008-03-03 17:30:34 EST
Need agent.
Comment 2 Rob Kenna 2008-03-04 10:08:51 EST
Created attachment 296747 [details]
Sybase failover Resource Agent

This was developed by Sybase
Comment 3 Rob Kenna 2008-03-04 10:09:51 EST
Created attachment 296748 [details]
Sybase RA Doc

Doc created by Sybase for the failover agent
Comment 4 Rob Kenna 2008-03-04 10:10:48 EST
Attachments added:

1) Resource Agent
2) Documentation
Comment 6 Lon Hohberger 2008-03-04 12:31:29 EST
I have committed this to my local git repository and pushed the changes to the
master branch (but not the RHEL5 branch yet).
Comment 8 Lon Hohberger 2008-03-11 13:58:59 EDT
This has been fixed and is in RHEL5 git repo.
Comment 12 Ludek Smid 2008-03-20 13:07:51 EDT
This exception was reviewed and approved for RHEL 5.2.
Comment 14 John Poelstra 2008-04-02 17:39:45 EDT
Greetings Red Hat Partner,

A fix for this issue should be included in the latest packages contained in
RHEL5.2-Snapshot3--available now on partners.redhat.com.  

Please test and confirm that your issue is fixed.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to ASSIGNED.

If you are receiving this message in Issue Tracker, please reply with a message
to Issue Tracker about your results and I will update bugzilla for you.  If you
need assistance accessing ftp://partners.redhat.com, please contact your Partner
Manager.

Thank you
Comment 15 John Poelstra 2008-04-09 18:45:28 EDT
Greetings Red Hat Partner,

A fix for this issue should be included in the latest packages contained in
RHEL5.2-Snapshot4--available now on partners.redhat.com.  

Please test and confirm that your issue is fixed.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to ASSIGNED.

If you are receiving this message in Issue Tracker, please reply with a message
to Issue Tracker about your results and I will update bugzilla for you.  If you
need assistance accessing ftp://partners.redhat.com, please contact your Partner
Manager.

Thank you
Comment 16 John Poelstra 2008-04-23 13:40:53 EDT
Greetings Red Hat Partner,

A fix for this issue should be included in the latest packages contained in
RHEL5.2-Snapshot6--available now on partners.redhat.com.  

We are nearing GA for 5.2 so please test and confirm that your issue is fixed ASAP.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to ASSIGNED.

If you are receiving this message in Issue Tracker, please reply with a message
to Issue Tracker about your results and I will update bugzilla for you.  If you
need assistance accessing ftp://partners.redhat.com, please contact your Partner
Manager.

Thank you
Comment 20 Lon Hohberger 2008-05-14 18:15:19 EDT
http://sources.redhat.com/git/?p=cluster.git;a=commit;h=94e8d0e1f5010f5cc7b263276da0e90821dffe95

Fixes the formatting problem in the agent.
Comment 23 Chris Ward 2008-10-21 09:01:41 EDT
Attention Partners! 

RHEL 5.3 public Beta will be released soon. This URGENT priority/severity bug should have a fix in place in the recently released Partner Alpha drop, available at ftp://partners.redhat.com. If you haven't had a chance yet to test this bug, please do so at your earliest convenience, to ensure the highest possible quality bits in the upcoming Beta drop.

Thanks, more information about Beta testing to come.

 - Red Hat QE Partner Management
Comment 24 Chris Ward 2008-11-18 13:10:11 EST
~~ Snapshot 3 is now available ~~ 

Snapshot 3 is now available for Partner Testing, which should contain a fix that resolves this bug. ISO's available as usual at ftp://partners.redhat.com. Your testing feedback is vital! Please let us know if you encounter any NEW issues (file a new bug) or if you have VERIFIED the fix is present and functioning as expected (add PartnerVerified Keyword).

Ping your Partner Manager with any additional questions. Thanks!
Comment 25 Chris Ward 2008-11-28 01:42:28 EST
~~ Attention ~~ Snapshot 4 is now available for testing @ partners.redhat.com ~~

Partners, it is vital that we get your testing feedback on this important bug fix / feature request. If you are unable to test, please clearly indicate this in a comment to this bug or directly with your partner manager. If we do not receive your test feedback, this bug is at risk from being dropped from the release.

If you have VERIFIED the fix, please add PartnerVerified to the Bugzilla Keywords field, along with a description of the test results. 

If you encounter a new bug, CLONE this bug and request from your Partner manager to review. We are no longer excepting new bugs into the release, bar critical regressions.
Comment 26 Chris Ward 2008-12-04 04:03:43 EST
Sybase, , what is the current status of this bug fix? The fix should be present in the latest RHEL5.3 Snapshot. Please test and send feedback ASAP.
Comment 28 Chris Ward 2008-12-05 04:03:00 EST
Lon, could you please let Sybase (jphui@sybase.com) know what exactly they need to test here? There seems to be a little confusion.
Comment 29 Chris Ward 2008-12-08 06:52:05 EST
~~ Snapshot 5 is now available @ partners.redhat.com ~~ 

Partners, RHEL 5.3 Snapshot 5 is now available for testing. Please send us your testing feedback on this important bug fix / feature request AS SOON AS POSSIBLE. If you are unable to test, indicate this in a comment or escalate to your Partner Manager. If we do not receive your test feedback, this bug will be AT RISK of being dropped from the release.

If you have VERIFIED the fix, please add PartnerVerified to the Bugzilla
Keywords field, along with a description of the test results. 

If you encounter a new bug, CLONE this bug and request from your Partner
manager to review. We are no longer excepting new bugs into the release, bar
critical regressions.
Comment 30 Chris Ward 2008-12-12 02:33:02 EST
Status update please. Lon, has Sybase been update as to what needs to be tested here?
Comment 31 Chris Ward 2008-12-16 11:28:31 EST
~~~ Attention Partners ~~~ The *last* RHEL 5.3 Snapshot 6 is now available at partners.redhat.com. A fix for this bug should be present. Please test and update this bug with test results as soon as possible.  If the fix present in Snap6 meets all the expected requirements for this bug, please add the keyword PartnerVerified. If any new bugs are discovered, please CLONE this bug and describe the issues encountered there.
Comment 33 Chris Ward 2009-01-08 05:12:14 EST
This one went out the door for 5.2.z without partner feedback. I assume then partner testing wasn't required. Removing OtherQA keyword.
Comment 34 errata-xmlrpc 2009-01-20 15:56:02 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0101.html
Comment 35 Lon Hohberger 2009-02-26 10:51:08 EST
Clearing NEEDINFO flag.

Note You need to log in before you can comment on or make changes to this bug.