Bug 435820 - LDAP + xdm login failure: No profile for user 'user' found [NEEDINFO]
LDAP + xdm login failure: No profile for user 'user' found
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: sabayon (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Ray Strode [halfline]
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-03 18:34 EST by Graham Leggett
Modified: 2014-06-02 09:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:20:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (minfrin)


Attachments (Terms of Use)

  None (edit)
Description Graham Leggett 2008-03-03 18:34:16 EST
After an RHEL5 system has been configured to log users in against an LDAP
server, and the LDAP based user is successfully able to log in at the console,
an attempt is made to log into X using gdm.

The attempt fails immediately, and the following message is logged to
.xsession-errors:

 localuser:minfrin being added to access control list
 No profile for user 'minfrin' found

There is no clear indication as to which program is logging this message, or
even if this message is relevant.

The user directory is empty - it has just been created from scratch.
Comment 1 Graham Leggett 2008-03-03 20:05:14 EST
Lots of digging uncovers this IRC log:

http://irclogs.ubuntu.com/2006/10/01/%23edubuntu.txt

It mentions that a package called "sabayon" might somehow be involved.

Sabayon is installed on the machine, but rpm -qi doesn't reveal anything
specific about what sabayon does.

Sabayon has an entry in /etc/pam.d, which links to /etc/pam.d/config-auth. The
only entry in config-auth to do with LDAP is the "auth" section in pam. I
suspect that system-config-authentication isn't setting the
/etc/pam.d/config-auth file correctly, need to dig further.
Comment 2 RHEL Product and Program Management 2014-03-07 08:45:47 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 3 RHEL Product and Program Management 2014-06-02 09:20:12 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.