Bug 435888 - Mouse behaving eradically in SDL fullscreen mode
Mouse behaving eradically in SDL fullscreen mode
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-mouse (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-04 05:44 EST by Hans de Goede
Modified: 2008-03-09 11:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-09 11:56:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.log without any xorg.conf (217.13 KB, text/plain)
2008-03-04 08:57 EST, Hans de Goede
no flags Details
xorg.log with xorg.conf with serverflags section as described (45.21 KB, text/plain)
2008-03-04 15:10 EST, Hans de Goede
no flags Details

  None (edit)
Description Hans de Goede 2008-03-04 05:44:12 EST
Description of problem:
-take a fully up2date rawhide system (x86_64, ati radeon 9800, ps/2 mouse
 in my case)
-install abuse "yum install abuse"
-start abuse from the applications menu (it needs some cmdline args to tell
 it where its data is)
-move mouse

Result:
-mouse jumps all over the place

Expected result:
-mouse should move normally

Notes:
-I tried both xorg.conf no input section, serverflags:
Section "ServerFlags"
    Option      "AllowEmptyInput" "True"
    Option      "AutoAddDevices" "True"
    Option      "AutoEnableDevices" "True"
EndSection
 and no xorg.conf at all

-Downgrading to F-8 xorg-x11-server-Xorg + drv ati,keyboard,mouse fixes this
Comment 1 Matěj Cepl 2008-03-04 05:57:46 EST
Can we get /var/log/Xorg.0.log from both with/without attempts as separate
uncompressed attachments to this log, please?
Comment 2 Hans de Goede 2008-03-04 08:57:16 EST
Created attachment 296737 [details]
xorg.log without any xorg.conf
Comment 3 Hans de Goede 2008-03-04 15:10:45 EST
Created attachment 296790 [details]
xorg.log with xorg.conf with serverflags section as described

Note:
I've done some more testing and couldn't reproduce this with other SDL mouse
using apps. Thie might be related to the low resolution (320x200) abuse uses.
Comment 4 Matěj Cepl 2008-03-05 15:33:50 EST
Trying to blame abuse. Let's see what happens ;-)
Comment 5 Matěj Cepl 2008-03-05 15:35:07 EST
Oh, sorry, I didn't know that. Chmm, then switching back to us.
Comment 6 Hans de Goede 2008-03-09 11:56:56 EDT
I'm happy to report that this is fixed with the latest xorg packages from
rawhide, closing.

Note You need to log in before you can comment on or make changes to this bug.