Bug 435898 - boo fails to build in rawhide with new nant
boo fails to build in rawhide with new nant
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nant (Show other bugs)
rawhide
All Linux
urgent Severity high
: ---
: ---
Assigned To: Paul F. Johnson
Fedora Extras Quality Assurance
:
Depends On: 441517
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-04 06:14 EST by Alex Lancaster
Modified: 2008-04-14 11:18 EDT (History)
1 user (show)

See Also:
Fixed In Version: 0.85-20.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-14 11:18:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch nant 0.85 for api changes (818 bytes, patch)
2008-03-27 06:45 EDT, David Nielsen
no flags Details | Diff

  None (edit)
Description Alex Lancaster 2008-03-04 06:14:42 EST
boo was causing broken deps in rawhide (presumably because a new version of nant
was released), so I took the liberty of rebuilding it:

http://koji.fedoraproject.org/koji/taskinfo?taskID=490181

but the build fails even when there are no fatal errors:

BUILD FAILED - 0 non-fatal error(s), 51 warning(s)

/builddir/build/BUILD/boo-0.8.1.2865/default.build(404,4):
External Program Failed: /builddir/build/BUILD/boo-0.8.1.2865/build/booc.exe
(return code was 255)

This has been causing broken deps in rawhide for almost 2 weeks now and the
rawhide freeze is coming soon, could this be looked at soon?
Comment 1 David Nielsen 2008-03-04 07:00:12 EST
the only reason we even have the beta version of nant is that the current stable
nant doesn't build on ppc.. I bumped the build to please the ppc arch team in
Pauls absence. 

I say we revert to a 0.85 based nant, 0.86 has turned out to be a lot more
painful than initial testing showed and the only gain is the ability to build on
ppc which frankly just isn't a worthwhile tradeoff given that the freeze is
coming up.. 
Comment 2 Alex Lancaster 2008-03-07 03:11:14 EST
(In reply to comment #1)
> the only reason we even have the beta version of nant is that the current stable
> nant doesn't build on ppc.. I bumped the build to please the ppc arch team in
> Pauls absence. 
> 
> I say we revert to a 0.85 based nant, 0.86 has turned out to be a lot more
> painful than initial testing showed and the only gain is the ability to build on
> ppc which frankly just isn't a worthwhile tradeoff given that the freeze is
> coming up.. 

I don't know whether it's actually possible to downgrade with introducing the
dreaded "Epoch:" tag which is awkward, see:

http://fedoraproject.org/wiki/Packaging/NamingGuidelines
Comment 3 David Nielsen 2008-03-27 06:45:15 EDT
Created attachment 299299 [details]
patch nant 0.85 for api changes

Paul, since you are the maintainer you get to decide what is the best course of
action here. However I have attached a little patch that makes the old nant
compile against what we have in Rawhide and it would be my recommendation to
rollback to that.
Comment 4 Alex Lancaster 2008-03-27 06:56:17 EDT
Comment on attachment 299299 [details]
patch nant 0.85 for api changes

Fixed MIME type.  This really should be opened as a nant bug, or this bug
should be moved to the nant component.
Comment 5 Alex Lancaster 2008-03-27 07:00:49 EDT
(In reply to comment #3)
> Created an attachment (id=299299) [edit]

> Paul, since you are the maintainer you get to decide what is the best course of
> action here. However I have attached a little patch that makes the old nant
> compile against what we have in Rawhide and it would be my recommendation to
> rollback to that.

Is this bug supposed to be applied to nant 0.86 or are you proposing rolling
back the whole nant package to 0.85?  In which case you need to introduce the
dreaded epoch (see comment #2).

Lastly I seem to recall that Paul was reducing his involvement with Fedora
packages except for mono related ones, so I'm not sure if this is package that
he is following carefully.  If no response is made within a week or, I'll try
and fix things so at least there are no broken deps in rawhide, since this
really should be fixed before F-9 final.
Comment 6 David Nielsen 2008-03-27 08:46:11 EDT
I am suggesting rolling back to 0.85, with the patch applied (it fixes a little
api change that caused the nant build to fail). 

It's the only sane thing to do, nant 0.86 is still in beta has has been since
early December, no real progress seems to be made in their CVS. I am not
comfortable risking shipping F9 with a beta of nant with this kind of bug
present and I doubt I have the technical skills to fix it myself. 0.85 worked
well, the only problem is lacking PPC support - Instead of trying to please the
arch team with this update I suggest that problem with handed off to them. I
have no ppc hardware and frankly I don't care about ppc as it has caused me
nothing but grief. 

Paul does tend to go away for extended periods so maybe it would be worth
getting a proper Mono SIG together and sharing ownership. It would help in
streamlining Mono support in Fedora, help us push for the same mono stack across
all supported platforms and aid in getting new mono packages into Fedora (I
currently have at least 3 mono based packages in need of review and nobody seems
comfortable doing the reviews since Mono specing is a little possessed skill).
Comment 7 Alex Lancaster 2008-04-02 04:27:16 EDT
Can you prepare a patch for the spec file to do the rollback, i.e. with the
Epoch tag and/or just push a rawhide build?   Then I can rebuild boo.  

This is going to be painful. :(
Comment 8 Alex Lancaster 2008-04-04 21:50:19 EDT
Ping?  David, are you willing to do the rollback, or do you want me to do it?
Comment 9 David Nielsen 2008-04-04 23:23:07 EDT
go ahead, I sadly have little time to get this done and tested due to other
Fedora work right now and it has been broken far to long.
Comment 10 Alex Lancaster 2008-04-07 22:02:59 EDT
(In reply to comment #9)
> go ahead, I sadly have little time to get this done and tested due to other
> Fedora work right now and it has been broken far to long.

OK, rolling back to 0.85 using Epoch.  Add the 0.85 API patch.  We'll see how
that goes.
Comment 11 Alex Lancaster 2008-04-07 22:15:18 EDT
I can't even get this damn thing to compile using the old 0.85 release:

http://koji.fedoraproject.org/koji/buildinfo?buildID=45460

which patches are now necessary and what order should I apply them in?  Here's
the spec file diff:

http://cvs.fedoraproject.org/viewcvs/rpms/nant/devel/nant.spec?r1=1.15&r2=1.18
Comment 12 Alex Lancaster 2008-04-07 22:17:57 EDT
On i386 the patches appear to apply, but it fails later in the build.  On x86_64
it fails upon applying the same patch, even though I'm rolling back to what
seemed to work in previous rawhide builds for 0.85.
Comment 13 David Nielsen 2008-04-08 05:54:05 EDT
You would need to first change:

-sed -i -e "s/@LIB@/%{_lib}/" NAnt.build
+sed -i -e "s/@LIBDIR@/%{_lib}/" NAnt.build

then rollback the app patch to the last version that worked:

http://cvs.fedoraproject.org/viewcvs/rpms/nant/devel/nant-app.patch?rev=1.3&view=markup

Since the one you are using appears to be for 0.86-beta1 not 0.85
Comment 14 David Nielsen 2008-04-08 05:55:36 EDT
Note I don't currently have a working F9 setup to test that with but it would
seem to work from a glance
Comment 15 Alex Lancaster 2008-04-08 06:15:47 EDT
(In reply to comment #14)
> Note I don't currently have a working F9 setup to test that with but it would
> seem to work from a glance

You can create an SRPM using:

make srpm

then do a koji scratch build:

koji build --scratch dist-f9 <path-to-srpm>.srpm

(In reply to comment #13)
> You would need to first change:
> 
> -sed -i -e "s/@LIB@/%{_lib}/" NAnt.build
> +sed -i -e "s/@LIBDIR@/%{_lib}/" NAnt.build

I think I did that.

> then rollback the app patch to the last version that worked: 
>
http://cvs.fedoraproject.org/viewcvs/rpms/nant/devel/nant-app.patch?rev=1.3&view=markup
> 
> Since the one you are using appears to be for 0.86-beta1 not 0.85

I believe I did that too: i.e. rollback the patch to the previous one.  I tested
that it applied correctly (and it does apply correctly on i386, but somehow
fails on x86_64).
Comment 16 Alex Lancaster 2008-04-08 08:59:46 EDT
OK, finally built:

http://koji.fedoraproject.org/koji/buildinfo?buildID=45460

Looks like I had pulled the patch from the F-8 branch rather than the previous
version from the F-9 branch.  The whole series of patches is pretty messy and
should probably be rationalized at some point, but at least it builds.  

I'll rebuild boo against it and request rel-eng to add it (and boo) to the final
F-9 release if possible.
Comment 17 David Nielsen 2008-04-08 09:49:45 EDT
so we might finally close this.. I'll uncock the champagne
Comment 18 Alex Lancaster 2008-04-08 09:56:37 EDT
boo-0.8.1.2865-3.fc9 rebuilt successfully:

http://koji.fedoraproject.org/koji/buildinfo?buildID=41174
Comment 19 Alex Lancaster 2008-04-08 09:57:26 EDT
(In reply to comment #17)
> so we might finally close this.. I'll uncock the champagne

Maybe... ;)  If you get a chance, can you test nant and/or boo?  (I've actually
never used it)
Comment 20 Alex Lancaster 2008-04-08 10:11:46 EDT
Does anything else use/compile against nant in rawhide?  i.e. anything that
would expect the previous (0.86) version of nant?
Comment 21 David Nielsen 2008-04-08 10:44:37 EDT
nothing springs to mind
Comment 22 Alex Lancaster 2008-04-08 20:58:06 EDT
(In reply to comment #21)
> nothing springs to mind

Looks like there are further issues with nant shipping things it shouldn't and
messing up Provides:  bug #441517.  I've Cc'ed you.
Comment 23 Alex Lancaster 2008-04-14 11:18:08 EDT
With new mono stack and nant (finally!) re-built and tagged f9-final, the boo
broken dep has gone away.  booish also appears to work fine for me.

So closing bug.

http://koji.fedoraproject.org/koji/buildinfo?buildID=46070


Note You need to log in before you can comment on or make changes to this bug.