Bug 435933 - SELinux is preventing bash (hald_t) "setsched" to <Unknown> (kernel_t).
SELinux is preventing bash (hald_t) "setsched" to <Unknown> (kernel_t).
Status: CLOSED DUPLICATE of bug 435197
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-04 10:00 EST by Eduard Benes
Modified: 2008-03-04 15:37 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-04 15:37:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eduard Benes 2008-03-04 10:00:48 EST
Setroubleshoot reports this alert after the machine resumes from suspend.

Summary:

SELinux is preventing bash (hald_t) "setsched" to <Unknown> (kernel_t).

Detailed Description:

SELinux denied access requested by bash. It is not expected that this access is
required by bash and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Or you can disable
SELinux protection altogether. Disabling SELinux protection is not recommended.
Please file a bug report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi)
against this package.

Additional Information:

Source Context                system_u:system_r:hald_t
Target Context                system_u:system_r:kernel_t
Target Objects                None [ process ]
Source                        bash
Source Path                   /bin/bash
Port                          <Unknown>
Host                          dhcp-lab-118.englab.brq.redhat.com
Source RPM Packages           bash-3.2-21.el5
Target RPM Packages           
Policy RPM                    selinux-policy-2.4.6-121.el5
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     dhcp-lab-118.englab.brq.redhat.com
Platform                      Linux dhcp-lab-118.englab.brq.redhat.com
                              2.6.18-83.el5 #1 SMP Thu Feb 21 12:14:23 EST 2008
                              i686 i686
Alert Count                   2
First Seen                    Tue Mar  4 15:42:55 2008
Last Seen                     Tue Mar  4 15:46:02 2008
Local ID                      938250bd-49ff-459f-a728-e8789fd4b795
Line Numbers                  

Raw Audit Messages            

host=dhcp-lab-118.englab.brq.redhat.com type=AVC msg=audit(1204641962.63:28): 
avc:  denied  { setsched } for  pid=8140 comm="bash" 
scontext=system_u:system_r:hald_t:s0 tcontext=system_u:system_r:kernel_t:s0 
tclass=process

host=dhcp-lab-118.englab.brq.redhat.com type=AVC msg=audit(1204641962.63:28): 
avc:  denied  { setsched } for  pid=8140 comm="bash" 
scontext=system_u:system_r:hald_t:s0 tcontext=system_u:system_r:kernel_t:s0 
tclass=process

host=dhcp-lab-118.englab.brq.redhat.com type=SYSCALL 
msg=audit(1204641962.63:28): arch=40000003 syscall=4 success=yes exit=3 a0=1 
a1=b7fea000 a2=3 a3=3 items=0 ppid=8134 pid=8140 auid=4294967295 uid=0 gid=0 
euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 
comm="bash" exe="/bin/bash" subj=system_u:system_r:hald_t:s0 key=(null)
Comment 1 Daniel Walsh 2008-03-04 15:37:26 EST

*** This bug has been marked as a duplicate of 435197 ***

Note You need to log in before you can comment on or make changes to this bug.