Bug 435938 - glibc obsoletes itself
glibc obsoletes itself
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-04 10:11 EST by Seth Vidal
Modified: 2008-03-11 05:21 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-11 05:21:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Seth Vidal 2008-03-04 10:11:02 EST
Glibc obsoletes itself.

rpm -q --obsoletes glibc 
shows:

zoneinfo  
libc-static  
libc-devel  
libc-profile  
libc-headers  
gencat  
locale  
ldconfig  
locale-ja  
glibc-profile  


rpm -q --provides glibc |  grep -E
'zoneinfo|locale|ldconfig|glibc-profile|gencat|libc-headers|locale-ja|locale|libc-devel|libc-profile|libc-gencat'

shows:

ldconfig


So, one of a couple of things need to happen. Either:
1. remove the obsoletes of ldconfig
2. version each and every obsolete on the list


2 is what should happen b/c that would be complying with the fedora packaging
guidelines.
Comment 1 Jakub Jelinek 2008-03-11 05:21:34 EDT
These have been dropped recently, except for glibc-profile obsoletes, which has
been versioned.

Note You need to log in before you can comment on or make changes to this bug.