Bug 435981 - Review Request: ocaml-lacaml - BLAS/LAPACK-interface for OCaml
Review Request: ocaml-lacaml - BLAS/LAPACK-interface for OCaml
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 433432
  Show dependency treegraph
 
Reported: 2008-03-04 14:02 EST by Richard W.M. Jones
Modified: 2008-03-05 17:25 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-05 17:25:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
panemade: fedora‑review+
kevin: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Comment 1 Parag AN(पराग) 2008-03-05 05:25:05 EST
Review:
+ package builds in mock (rawhide i386).
koji build => http://koji.fedoraproject.org/koji/taskinfo?taskID=491377
+ rpmlint is silent for SRPM and for RPM.
+ source files match upstream.
dd42769a777f9dfc086b1d23e2d6ed44  lacaml-4.3.0.tar.bz2
+ package meets naming and packaging guidelines.
+ specfile is properly named, is cleanly written
+ Spec file is written in American English.
+ Spec file is legible.
+ dist tag is present.
+ build root is correct.
+ license is open source-compatible.
+ License text is included in package.
+ %doc files present.
+ BuildRequires are proper.
+ Compiler flags are honored correctly.
+ defattr usage is correct.
+ %clean is present.
+ package installed properly.
+ Macro use appears rather consistent.
+ Package contains code.
+ no .pc file present.
+ -devel subpackage exists.
+ no .la files.
+ no translations are available.
+ Does owns the directories it creates.
+ no duplicates in %files.
+ file permissions are appropriate.
+ no scriptlets are used.
+ Not a GUI app.
+ Package ocaml-lacaml-4.3.0-2.fc9 =>
  Provides: dlllacaml_stubs.so ocaml(Lacaml) = c0b21ee01ef3e87111e8dac3a52c5c44
 Requires: libblas.so.3 libc.so.6 libc.so.6(GLIBC_2.0) libc.so.6(GLIBC_2.1.3)
liblapack.so.3 ocaml(Array) = aa8e3cd5824f9bb40b93fcd38d0c95b5 ocaml(Bigarray) =
e881a834bafaaa24bc612d94119cc0f5 ocaml(Buffer) =
f6cef633ea14963b84b79c4095c63dc3 ocaml(Complex) =
bb333e8e4cda78107ccf27048ca40492 ocaml(Consistbl) =
47f9cdffda6ba2de99c8e9f0c0c1b34d ocaml(Digest) =
a5dd2d89492338578de12105e88c803f ocaml(Env) = 6d0215253b3fde95601c34944cacb607
ocaml(Format) = 35fe566f7a37d8991a5c822bd1463949 ocaml(Hashtbl) =
083f2c94b44ff4e0b3220aaea6a783b4 ocaml(Ident) = ba1acc56fc179d27bd55278cbc2abf40
ocaml(Int32) = 711321870c949bd3bbdd092d9bae92e4 ocaml(Int64) =
f8f7e2e4c0667ead94596040b12e732d ocaml(Lexing) =
b1793496643444d3762dd42bebe2cfe3 ocaml(List) = da1ce9168f0408ff26158af757456948
ocaml(Location) = eed044ad1204a633caad97bdd9048f8c ocaml(Longident) =
46fb8aad4fb2c12a0f301b02d8139f07 ocaml(Map) = dedde7683d54ae7db1eb97cc868dd047
ocaml(Nativeint) = e79cdc4d3575c2ed044955cb7ef49aca ocaml(Obj) =
5cfae708052c692ea39d23ed930fd64d ocaml(Outcometree) =
6674fbd870cb2522aca4d851f3559202 ocaml(Path) = d8bc8e7163bac3a9a0a93f1cb07092d1
ocaml(Pervasives) = 8ba3d1faa24d659525c9025f41fd0c57 ocaml(Primitive) =
43a2770aed8fbcc536ab39d717fe9a7b ocaml(Printf) =
5dbbf45a03b54e6dbfcf39178d0d6341 ocaml(Random) =
9936935480b36bcbc716ee513f37876c ocaml(Set) = 7da14e671a035f12386ace3890018ef3
ocaml(String) = 2c162ab314b2f0a2cfd22d471b2e21ab ocaml(Toploop) =
ead8879d71c4d5137fe5100fdd682a0b ocaml(Types) = df897aed3fc89c2129322c17067857b8
ocaml(Unix) = 9a46a8db115947409e54686ada118599 ocaml(Warnings) =
abcb1589615da86f20f475b0ed3bbabc ocaml(runtime) = 3.10.1
+ Package ocaml-lacaml-devel-4.3.0-2.fc9 =>
  ocaml-lacaml = 4.3.0-2.fc9
+ Followed ocaml packaging guidelines.

NOTE: I am approving this as following rule is looks valid here
=======================================================================
.ml files are not normally included. The exception is if the file describes a
module signature and there is no corresponding .mli file, then the .ml file
should be included.
=========================================================================
/usr/lib/ocaml/lacaml/complex32.cmx
/usr/lib/ocaml/lacaml/complex32.ml
/usr/lib/ocaml/lacaml/complex64.cmx
/usr/lib/ocaml/lacaml/complex64.ml
/usr/lib/ocaml/lacaml/float32.cmx
/usr/lib/ocaml/lacaml/float32.ml
/usr/lib/ocaml/lacaml/float64.cmx
/usr/lib/ocaml/lacaml/float64.ml
/usr/lib/ocaml/lacaml/impl.cmx
/usr/lib/ocaml/lacaml/impl.ml

APPROVED.
Comment 2 Richard W.M. Jones 2008-03-05 05:37:59 EST
About the *.cmx files:  That rule applies especially in this situation
because we want the cross-module optimizations in numeric code.

New Package CVS Request
=======================
Package Name: ocaml-lacaml
Short Description: BLAS/LAPACK-interface for OCaml
Owners: rjones
Branches: F-8
InitialCC: rjones
Cvsextras Commits: yes
Comment 3 Kevin Fenzi 2008-03-05 14:47:20 EST
cvs done.
Comment 4 Richard W.M. Jones 2008-03-05 17:25:41 EST
Committed & built.

Note You need to log in before you can comment on or make changes to this bug.