Bug 435998 - anaconda traceback in migrateFilesystems after filesystems are formatted but before packages are installed
anaconda traceback in migrateFilesystems after filesystems are formatted but ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.2
All Linux
urgent Severity urgent
: beta
: ---
Assigned To: Peter Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-04 15:16 EST by Mike Gahagan
Modified: 2008-05-21 11:33 EDT (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2008-0397
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:33:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of traceback 1/3 (74.38 KB, image/png)
2008-03-04 15:16 EST, Mike Gahagan
no flags Details
anaconda traceback screenshot 2/3 (71.28 KB, image/png)
2008-03-04 15:17 EST, Mike Gahagan
no flags Details
Anaconda traceback 3/3 (64.26 KB, image/png)
2008-03-04 15:17 EST, Mike Gahagan
no flags Details
log of traceback from i386 baremetal system (46.45 KB, application/octet-stream)
2008-03-04 15:37 EST, Mike Gahagan
no flags Details
updates.img to test with (150.00 KB, application/octet-stream)
2008-03-04 16:14 EST, Peter Jones
no flags Details
updates.img to test with (150.00 KB, application/octet-stream)
2008-03-04 16:17 EST, Peter Jones
no flags Details
the patch applied to create the updates.img (559 bytes, patch)
2008-03-04 16:19 EST, Peter Jones
no flags Details | Diff
log files from second traceback in comment 11 - includes partition/lvm information (47.48 KB, application/x-bzip2)
2008-03-04 16:40 EST, Mike Gahagan
no flags Details
anacdump.txt (420.75 KB, text/plain)
2008-03-05 13:43 EST, James Laska
no flags Details

  None (edit)
Description Mike Gahagan 2008-03-04 15:16:35 EST
Description of problem:
anaconda traceback in migrateFilesystems after filesystems are formatted but
before packages are installed when doing an http install i386. 

Version-Release number of selected component (if applicable):
0303.0 5.2 tree

How reproducible:
always

Steps to Reproduce:
1.start http install on i386 system (text or gui), skip install key
2.Disk/lvm was pre-partitioned, not sure if that had anything to do with
reproducing the problem, but I chose "create custom layout" and set the proper
mountpoints for the pre-existing partitions
3.choose some packages to install (I only chose "software development")
4. click ok to start the install, watch traceback appear after disk(s) are
formatted, but just before package installation would start.
  
Actual results:
anaconda crashes

Expected results:
Install should finish.

Additional info:
I currently have logs in the form of screenshots of the xen instance, will have
a more complete log on bare-metal shortly

The same systems were installed with the 0225.2 tree last week without incident.
Comment 1 Mike Gahagan 2008-03-04 15:16:35 EST
Created attachment 296791 [details]
screenshot of traceback 1/3
Comment 2 Mike Gahagan 2008-03-04 15:17:23 EST
Created attachment 296792 [details]
anaconda traceback screenshot 2/3
Comment 3 Mike Gahagan 2008-03-04 15:17:52 EST
Created attachment 296793 [details]
Anaconda traceback 3/3
Comment 4 Mike Gahagan 2008-03-04 15:37:34 EST
Created attachment 296797 [details]
log of traceback from i386 baremetal system
Comment 5 Mike Gahagan 2008-03-04 15:38:21 EST
traceback from logfile attachment in comment 4

Traceback (most recent call first):
  File "/usr/lib/anaconda/fsset.py", line 1834, in migrateFilesystems
    entry.options = entry.options.replace(",_netdev",",_rnetdev")
  File "/usr/lib/anaconda/packages.py", line 127, in doMigrateFilesystems
    anaconda.id.fsset.migrateFilesystems (anaconda.rootPath)
  File "/usr/lib/anaconda/dispatch.py", line 201, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 124, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1018, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 243, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 1045, in handleRenderCallback
    self.currentWindow.renderCallback()
AttributeError: 'NoneType' object has no attribute 'replace'

Local variables in innermost frame:
entry: fsentry -- device: VolGroup00/LogVol00   mountpoint: /
  fsystem: ext3 format: True
  ismounted: 1  options: 'defaults'
  bytesPerInode: 4096 label: None

self: <fsset.FileSystemSet instance at 0xb7bebf0c>
chroot: /mnt/sysimage
mountpoint: /
Comment 6 James Laska 2008-03-04 16:08:26 EST
_rnetdev ... hrmm.  Adding pjones to the cc list for some thoughts.
Comment 7 Mike Gahagan 2008-03-04 16:11:14 EST
wiping the partition table on the drive, then initilizing the drive in anaconda
apperantly gets around this bug.. I'll try doing a second install to the same
partitions/LV's once this install completes.
Comment 8 Peter Jones 2008-03-04 16:14:32 EST
Created attachment 296804 [details]
updates.img to test with

Please try to replicate with the attached update image.
Comment 9 Peter Jones 2008-03-04 16:17:09 EST
Created attachment 296806 [details]
updates.img to test with

(Sorry about that last one, it may have been misconstructed.)
Comment 10 Peter Jones 2008-03-04 16:19:41 EST
Created attachment 296807 [details]
the patch applied to create the updates.img
Comment 11 Mike Gahagan 2008-03-04 16:25:43 EST
updated reproducer instructions:

1. Install the 0303.0 tree to a blank (unpartitioned drive)
2. Run install of 0303.0 tree again, create custom partition layout, choose
pre-existing partitoins/LV's from last install, format and make the same
mountpoints as before
3. choose some packages to install (I only chose "software development")
4. click ok to start the install, watch traceback appear after disk(s) are
formatted, but just before package installation would start.
Comment 12 Mike Gahagan 2008-03-04 16:40:18 EST
Created attachment 296813 [details]
log files from second traceback in comment 11 - includes partition/lvm information
Comment 13 Mike Gahagan 2008-03-04 17:05:08 EST
I started an install with the updates.img in comment 9 .. so far so good.. it is
installing packages now... I'll provide another update once it is done.
Comment 14 Mike Gahagan 2008-03-04 17:15:50 EST
Install using the updates.img file was successful.
Comment 16 Chris Lumens 2008-03-05 11:18:33 EST
This will be fixed in anaconda-11.1.2.106.
Comment 18 James Laska 2008-03-05 13:43:23 EST
Created attachment 296907 [details]
anacdump.txt

reproduced without dmraid devices.

The trick seems to be:
 - create custom partition layout
 - reuse *exact* same partition layout already on disk
Comment 20 Mike Gahagan 2008-03-06 10:33:06 EST
I agree that it is probably ok for the beta to go out like this, but is it too
late to document this and point users to the updates.img here? Might save some
new bug reports for something we have already fixed if nothing else.

Comment 21 Alexander Todorov 2008-03-06 10:36:56 EST
Another partitions re-using bug. Most likely unrelated:
https://bugzilla.redhat.com/show_bug.cgi?id=246715
Comment 24 Alexander Todorov 2008-03-06 12:11:21 EST
kistart reproducer from Xen guest with one disk 4GB

initial install (autopart)
---------------------------------------------------------------------
clearpart --all --drives=xvda
part /boot --fstype ext3 --size=100 --ondisk=xvda
part pv.2 --size=0 --grow --ondisk=xvda
volgroup VolGroup00 --pesize=32768 pv.2
logvol swap --fstype swap --name=LogVol01 --vgname=VolGroup00 --size=528 --grow
--maxsize=1056
logvol / --fstype ext3 --name=LogVol00 --vgname=VolGroup00 --size=1024 --grow
---------------------------------------------------------------------

second install
---------------------------------------------------------------------
part /boot --fstype ext3 --onpart xvda1
part pv.2 --noformat --onpart xvda2
volgroup VolGroup00 --noformat --useexisting --pesize=32768 pv.2
logvol swap --useexisting --fstype swap --name=LogVol01 --vgname=VolGroup00
--size=1056
logvol / --useexisting --fstype ext3 --name=LogVol00 --vgname=VolGroup00 --size=2816
---------------------------------------------------------------------

note the --onpart options and that we're missing the clearpart command.
Comment 28 errata-xmlrpc 2008-05-21 11:33:25 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0397.html

Note You need to log in before you can comment on or make changes to this bug.