Bug 436031 - Service does not start
Summary: Service does not start
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: mediatomb (Show other bugs)
(Show other bugs)
Version: 8
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Marc Wiriadisastra
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-03-04 22:07 UTC by Richard Körber
Modified: 2008-03-05 21:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-05 21:31:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Richard Körber 2008-03-04 22:07:47 UTC
Description of problem:
When invoking "service mediatomb start" on a non-English installation, the start
fails and an error is reported.

Version-Release number of selected component (if applicable):
mediatomb-0.10.0-8.fc8

How reproducible:
always

Steps to Reproduce:
1. Set up a non-English Fedora
2. Install mediatomb
3. Try to start the service
  
Actual results:
An error is reported and the service fails to start. On a German installation,
the error is: "Applying multicast settings to eth1... Starting mediatomb:
mediatomb: Diese Option benötigt ein Argument -- »i«"

Expected results:
The service starts successfully.

Additional info:
The issue is caused by /etc/init.d/mediatomb, line 41, where ifconfig is invoked
and the output is grepped against "inet addr". On a German installation, the
appropriate ifconfig line is "inet Adresse", so the grep won't match anything.
The line should be language independent.

Comment 1 Marc Wiriadisastra 2008-03-04 22:15:54 UTC
Can you try the one in updates-testing being version 0.11 and see if that works
please.

Comment 2 Richard Körber 2008-03-04 22:21:50 UTC
Yes, 0.11 works. Thank you! :-)


Note You need to log in before you can comment on or make changes to this bug.