Bug 436056 - Missing Dependency: /usr/lib/eclipse/plugins/org.eclipse.swt.gtk.linux.x86_3.3.0.v3346.jar
Missing Dependency: /usr/lib/eclipse/plugins/org.eclipse.swt.gtk.linux.x86_3....
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-04 21:00 EST by Reindl Harald
Modified: 2008-03-05 09:27 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-05 09:27:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Reindl Harald 2008-03-04 21:00:37 EST
I have no idea how to solve the following problem
On my notebook eclipse-install worked fine, but on my workstation a get
everytime the follwoing errors. Of course if i only try "yum install
eclipse-cdt"... Hope someone can help

---> Package ant-jdepend.i386 0:1.7.0-1jpp.2.fc8 set to be updated
--> Processing Dependency: jdepend for package: ant-jdepend
---> Package jetty.i386 0:5.1.12-1jpp.9.fc8 set to be updated
---> Package ant-apache-regexp.i386 0:1.7.0-1jpp.2.fc8 set to be updated
---> Package eclipse-rcp.i386 1:3.3.0-31.fc8 set to be updated
--> Processing Dependency:
/usr/lib/eclipse/plugins/org.eclipse.swt.gtk.linux.x86_3.3.0.v3346.jar for
package: eclipse-rcp
--> Processing Dependency: libswt3-gtk2 = 1:3.3.0-31.fc8 for package: eclipse-rcp
--> Processing Dependency: icu4j-eclipse >= 3.6.1 for package: eclipse-rcp
--> Processing Dependency: libswt3-gtk2 = 1:3.3.0-31.fc8 for package: eclipse-rcp
---> Package ant-apache-log4j.i386 0:1.7.0-1jpp.2.fc8 set to be updated
---> Package ant-trax.i386 0:1.7.0-1jpp.2.fc8 set to be updated
---> Package ant-commons-logging.i386 0:1.7.0-1jpp.2.fc8 set to be updated
---> Package ant-swing.i386 0:1.7.0-1jpp.2.fc8 set to be updated
---> Package ant-nodeps.i386 0:1.7.0-1jpp.2.fc8 set to be updated
---> Package ant-apache-resolver.i386 0:1.7.0-1jpp.2.fc8 set to be updated
--> Running transaction check
---> Package icu4j-eclipse.i386 0:3.6.1-1jpp.3.fc8 set to be updated
---> Package jdepend.i386 0:2.6-6jpp.1 set to be updated
---> Package eclipse-platform.i386 1:3.3.0-31.fc8 set to be updated
--> Processing Dependency:
/usr/lib/eclipse/plugins/org.eclipse.swt.gtk.linux.x86_3.3.0.v3346.jar for
package: eclipse-platform
---> Package eclipse-rcp.i386 1:3.3.0-31.fc8 set to be updated
--> Processing Dependency:
/usr/lib/eclipse/plugins/org.eclipse.swt.gtk.linux.x86_3.3.0.v3346.jar for
package: eclipse-rcp
--> Processing Dependency: libswt3-gtk2 = 1:3.3.0-31.fc8 for package: eclipse-rcp
--> Processing Dependency: libswt3-gtk2 = 1:3.3.0-31.fc8 for package: eclipse-rcp
---> Package jzlib.i386 0:1.0.7-4jpp.1 set to be updated
---> Package junit.i386 0:3.8.2-3jpp.3.fc8 set to be updated
--> Finished Dependency Resolution
Error: Missing Dependency:
/usr/lib/eclipse/plugins/org.eclipse.swt.gtk.linux.x86_3.3.0.v3346.jar is needed
by package eclipse-rcp
Error: Missing Dependency: libswt3-gtk2 = 1:3.3.0-31.fc8 is needed by package
eclipse-rcp
Error: Missing Dependency:
/usr/lib/eclipse/plugins/org.eclipse.swt.gtk.linux.x86_3.3.0.v3346.jar is needed
by package eclipse-platform
Comment 1 Andrew Overholt 2008-03-05 08:51:35 EST
Was this perhaps a bad mirror?
Comment 2 Reindl Harald 2008-03-05 09:19:58 EST
No, but i found out late in the night the reason
Tried "yum remove libswt3-gtk2", had no other dependencies and after this it
worked - I do not know why the package was installed, but someone should take a
look whats going on with this conflict.
Comment 3 Andrew Overholt 2008-03-05 09:27:40 EST
libswt3-gtk2 is SWT, the graphical toolkit used by Eclipse.  It is a necessary
dependency of Eclipse graphical stuff (RCP being the lowest level).  It comes
from the eclipse SRPM.  There is no conflict.  The file dependency is to deal
with multilib crap.

Note You need to log in before you can comment on or make changes to this bug.