Bug 436061 - [PATCH] pci_device_get_vendor_name always returns unknown vendor
[PATCH] pci_device_get_vendor_name always returns unknown vendor
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: libpciaccess (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-04 22:51 EST by Doug Chapman
Modified: 2008-03-06 14:23 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-06 14:23:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix NULL check in populate_vendor (504 bytes, patch)
2008-03-04 22:51 EST, Doug Chapman
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 14818 None None None Never

  None (edit)
Description Doug Chapman 2008-03-04 22:51:31 EST
Description of problem:
I have already filed a BZ at freedesktop.org for this issue:
https://bugs.freedesktop.org/show_bug.cgi?id=14818

I don't know if this is causing any real issues but I can imagine this might
confuse some of our tools that try to automagically configure X.  I am filing
this here just in case this explains any other bugs we are seeing.  If not I am
fine waiting for the next pull of libpciaccess.  I discovered this while trying
to determine why the ati driver on ia64 isn't working.


When the X server calls pci_device_get_vendor_name() it always gets NULL back. 
I traced this down to libpciaccess in populate_vendor():




    231                 if (vend->vendor_name != NULL) {
    232                     vend->vendor_name = strdup( & buf[ num_tabs + 6 ]
);
    233                 }


I assume the intention here was not to overwrite an old vendor and create a
memory leak but it appears this should be == NULL.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Doug Chapman 2008-03-04 22:51:31 EST
Created attachment 296841 [details]
patch to fix NULL check in populate_vendor
Comment 2 Adam Jackson 2008-03-06 14:23:14 EST
Fixed upstream, will do a new libpciaccess release and update rawhide shortly. 
Thanks!

Note You need to log in before you can comment on or make changes to this bug.