This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 436125 - tg3 driver freezes kernel on Fujitsu Siemens Primergy Econel 200 (BCM5705)
tg3 driver freezes kernel on Fujitsu Siemens Primergy Econel 200 (BCM5705)
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.6
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Andy Gospodarek
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-05 10:35 EST by Alexey Butkevich
Modified: 2008-12-19 08:54 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-19 08:54:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
The output produced by "sosreport" is attached. (1017.25 KB, application/octet-stream)
2008-03-05 10:35 EST, Alexey Butkevich
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 204284 None None None Never

  None (edit)
Description Alexey Butkevich 2008-03-05 10:35:08 EST
Description of problem:

The kernel freezes trying to load tg3 network driver.

The maschine is FUJITSU SIEMENS PRIMERGY Econel 200, two Intel Xeon 2.8GHz, SMP
kernel.

This bug looks very similar to the bug 204284 reported 2006-08-28.

Version-Release number of selected component (if applicable):

EL 4 Update 6 2.6.9-67.0.4.EL.smp

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Alexey Butkevich 2008-03-05 10:35:08 EST
Created attachment 296887 [details]
The output produced by "sosreport" is attached.
Comment 2 Andy Gospodarek 2008-12-18 09:47:57 EST
Have you tried our 4.7 kernels?  I'd hate to try and chase down something that is already fixed.
Comment 3 Alexey Butkevich 2008-12-18 10:12:37 EST
No, I haven't tried other kernels. In fact, I've installed other network card and I'm now working with it.

(In reply to comment #2)
> Have you tried our 4.7 kernels?  I'd hate to try and chase down something that
> is already fixed.
Comment 4 Andy Gospodarek 2008-12-18 11:03:15 EST
Unfortunately I do not have one of these systems available, so it will be difficult for me to understand the problem without more information.

I see that you are using a Broadcom 5705 (which has been supported for quite some time), so this doesn't seem like a problem with unsupported hardware.

Are you able to reboot with the tg3-driver removed from the blacklist and capture output when the freeze occurs?  I wonder if there is any interesting output from the driver that will help debug this issue?

It would also be nice to see if you could try a later kernel since there have been many tg3-driver updates since 2.6.9-67.
Comment 5 Andy Gospodarek 2008-12-18 15:31:26 EST
This system has been previously certified as supported by RH as early as 4.1, so I do not expect there to be problems with a normal, working system.  Once we get some logs from the failures, we can try and determine if this is a problem related to configuration, firmware/bios, or hardware.
Comment 6 Alexey Butkevich 2008-12-19 06:04:08 EST
I tried to boot with tg3 enabled, but the system failed to start. It gave the message

Initializing hardware... storage

and hung forever after that.

The current kernel version is  2.6.9-78.0.8.ELsmp, but it seems not to be helpful.

I think we can now stop with this problem. I have disabled tg3, installed other network card and I'm now working with it without any problem. Of course, we can debug this problem further, but will it be really useful? So, I offer to stop with it.

(In reply to comment #4)
> Unfortunately I do not have one of these systems available, so it will be
> difficult for me to understand the problem without more information.
> 
> I see that you are using a Broadcom 5705 (which has been supported for quite
> some time), so this doesn't seem like a problem with unsupported hardware.
> 
> Are you able to reboot with the tg3-driver removed from the blacklist and
> capture output when the freeze occurs?  I wonder if there is any interesting
> output from the driver that will help debug this issue?
> 
> It would also be nice to see if you could try a later kernel since there have
> been many tg3-driver updates since 2.6.9-67.
Comment 7 Andy Gospodarek 2008-12-19 08:54:52 EST
If you are happy using the system with the additional card, I am willing to close this bug.

Note You need to log in before you can comment on or make changes to this bug.