Bug 436193 - pirut/pup is missing an icon
pirut/pup is missing an icon
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pirut (Show other bugs)
5.2
All Linux
medium Severity low
: rc
: ---
Assigned To: James Antill
Petr Sklenar
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-05 15:44 EST by Michal Nowak
Modified: 2013-04-12 15:35 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-20 05:14:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Icon still not there (32.85 KB, image/png)
2008-03-19 13:38 EDT, Michal Nowak
no flags Details
Old pirut with big icon (33.24 KB, image/png)
2008-04-14 04:23 EDT, Michal Nowak
no flags Details
New pirut with small icon (15.83 KB, image/png)
2008-04-14 04:23 EDT, Michal Nowak
no flags Details

  None (edit)
Description Michal Nowak 2008-03-05 15:44:30 EST
Description of problem:

in recent version of pirut-1.3.28-10.el5 (actually the `pup` application)
there's missing icon on the top of the screen before Package Updater.

When started in terminal there's just expected msg
"Loading "rhnplugin" plugin"

How reproducible:
always

Steps to Reproduce:
1. run pup
2.
3.
  
Actual results:
no icon

Expected results:
icon
Comment 1 Michal Nowak 2008-03-13 10:31:07 EDT
pirut-1.3.28-11.el5 is still affected. 
Comment 2 James Antill 2008-03-13 10:54:27 EDT
 You're right ... I lost track of this BZ.
Comment 3 James Antill 2008-03-13 10:56:30 EDT
 Proposing for exception because it should just be a minor icon path/etc. thing.
No "real" code change required.
Comment 6 Michal Nowak 2008-03-19 13:38:21 EDT
Created attachment 298550 [details]
Icon still not there

I don't see the icon where it should be even in the new -12.el5 release. Tested
on two machines, nothing interesting seen in stdout. It's possible that the
icon will be there when there was not the error msg, but I believe that the
icon should be there in any cases from the beginning.
Comment 7 James Antill 2008-03-19 16:24:31 EDT
 Arggh ... I was looking at the wrong icon. Obviously, now, you mean the one
within the window.
Comment 8 James Antill 2008-03-19 16:29:52 EDT
 Can you try changing /usr/share/pirut/ui/pup.glade, where it says:

                <property name="icon_name">system-software-update</property>

...change it to:

                <property name="icon_name">pup</property>

...just to make sure I've got it right this time :).
Comment 9 James Antill 2008-03-19 17:06:16 EDT
n/m I've just checked it via. rhts, and now both are fixed in -13.
Comment 10 Michal Nowak 2008-03-20 04:22:46 EDT
Cool, fixed now. Thanks.
Comment 12 Michal Nowak 2008-04-14 04:22:31 EDT
The image in pirut-1.3.28-13.el5.noarch is wrong. See attached screenshots from
1.2.x and 1.3.x versions. Please use the big image there.
Comment 13 Michal Nowak 2008-04-14 04:23:11 EDT
Created attachment 302310 [details]
Old pirut with big icon
Comment 14 Michal Nowak 2008-04-14 04:23:39 EDT
Created attachment 302311 [details]
New pirut with small icon
Comment 16 Denise Dumas 2008-04-14 14:30:07 EDT
Too late to change in 5.2 at this point, moving to 5.3 fast track.
Comment 22 RHEL Product and Program Management 2008-09-19 18:23:11 EDT
This bugzilla was reviewed by QE as a non-FasTrack request.
It has since been proposed for FasTrack. The qa_ack has 
been reset. QE needs to re-review this bugzilla for FasTrack.
Comment 28 Petr Sklenar 2010-01-04 11:35:05 EST
testing procedure:
old pup: small icon
new pup: there is nice BIG icon now, its like Michal Nowak's screenshot from Comment #13 

tested with pirut-1.3.28-16.el5 on all arch
Comment 30 errata-xmlrpc 2010-01-20 05:14:44 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0058.html

Note You need to log in before you can comment on or make changes to this bug.