Bug 436201 - Multipath doesn't wait for devices to be initialized on boot
Multipath doesn't wait for devices to be initialized on boot
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
4.6
All Linux
low Severity low
: rc
: ---
Assigned To: Ben Marzinski
Corey Marthaler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-05 16:05 EST by Ben Marzinski
Modified: 2010-01-11 21:31 EST (History)
13 users (show)

See Also:
Fixed In Version: RHBA-2008-0764
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 16:03:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Marzinski 2008-03-05 16:05:21 EST
Description of problem:
When you boot some systems with multipath devices, the devices are not correctly
created.  This is because when multipath is run during the boot process, the
devices are not completely initialized yet.

How reproducible:
Easy if you have the right hardware.  It seems to happen most commonly with EMC
storage

Steps to Reproduce:
1. configure multipath on a system.
2. reboot
3.
  
Actual results:
not all multipath devices are created.

Expected results:
all multipath devices should be created.

Additional info:
Comment 1 Ben Marzinski 2008-03-05 20:27:53 EST
To fix this, you simply need to make multipath check if the device is not
initialized yet, and wait for it if it's not, like multipath does in RHEL5
Comment 2 RHEL Product and Program Management 2008-03-05 20:37:58 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 errata-xmlrpc 2008-07-24 16:03:09 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0764.html

Note You need to log in before you can comment on or make changes to this bug.