Bug 436202 - ipw3945 on Dell Precision M6300 inconsistently able to reconnect after suspend
ipw3945 on Dell Precision M6300 inconsistently able to reconnect after suspend
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: NetworkManager (Show other bugs)
5.2
All Linux
low Severity medium
: rc
: ---
Assigned To: Dan Williams
desktop-bugs@redhat.com
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-05 16:06 EST by Suzanne Hillman
Modified: 2013-02-19 00:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-19 00:14:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suzanne Hillman 2008-03-05 16:06:50 EST
Description of problem:
ipw3945 on Dell Precision M6300 inconsistently able to reconnect after suspend.

As per my comment in bug #362421, I have seen very inconsistent behavior on
actually connecting to a WAP after a suspend, where sometimes it tries three
times, keeps losing the connection, but succeeds on the third try. Other times,
it entirely fails to connect. And this is to a WAP running wpa personal, so
radius is not getting in the way, and another machine is perfectly happily
connected to it.

Hibernate seems to pretty much be able to connect after resuming. Not sure why
suspend cannot always do so.

It is also visibly slower - entirely aside from built in delays to _starting_ to
connect. Or at least it seems so - as compared to on boot or during normal use.

Version-Release number of selected component (if applicable):
NetworkManager-0.6.4-7.el5

How reproducible:
Most of the time.

Steps to Reproduce:
1. Get the system specified above, with the relevant NM version.
2. Connect to a WAP.
3. Suspend, then resume.
  
Actual results:
May or may not be able to connect, at all, or without trying multiple times.

Expected results:
Should just work.

Additional info:
Not a regression. Cannot be, since previously the device was unavailable after
suspend or hibernate.
Comment 3 Dan Williams 2013-02-19 00:14:47 EST
Not going to get fixed for RHEL5 but shouldn't be a problem in RHEL6.

Note You need to log in before you can comment on or make changes to this bug.