Bug 436225 - totem doesn't play one ogg movie
totem doesn't play one ogg movie
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: totem (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-05 18:50 EST by Matěj Cepl
Modified: 2008-05-21 04:18 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 04:18:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matěj Cepl 2008-03-05 18:50:20 EST
Description of problem:
When trying to play attachment 296894 [details] (which is attached to bug 436142) with a
standalone totem and downloaded OGG file, totem doesn't do anything for a long
time (approx. minute, but I haven't timed it exactly) and then plays the movie
without a problem.

Both ffplay and gst-launch playbin work on the file without any problems.

Version-Release number of selected component (if applicable):
gstreamer-plugins-ugly-0.10.6-5.lvn8
gstreamer-plugins-base-devel-0.10.15-3.fc8
totem-2.20.1-2.fc8
gstreamer-plugins-bad-devel-0.10.5-14.lvn8
gstreamer-plugins-good-devel-0.10.6-7.fc8
gstreamer-plugins-bad-0.10.5-14.lvn8
gstreamer-plugins-pulse-0.9.5-0.4.svn20070924.fc8
gstreamer-plugins-schroedinger-0.9.0-1.fc8
gstreamer-plugins-good-0.10.6-7.fc8
totem-plparser-2.20.1-2.fc8
totem-galago-2.20.1-2.fc8
gstreamer-plugins-base-0.10.15-3.fc8
totem-mozplugin-2.20.1-2.fc8
firefox-2.0.0.12-1.fc8
nspluginwrapper-0.9.91.5-17.fc8

How reproducible:
100%

Steps to Reproduce:
1.download the movie to the local hard drive
2.totem filename.ogg
3.
  
Actual results:
long time nothing, then the movie is played

Expected results:
working with the same delay as gst-launch playbin and ffplay (i.e., no delay at
all)


Additional info:
[matej@viklef tmp]$ GST_DEBUG_NO_COLOR=1 GST_DEBUG=*:2 totem video.ogg 2> log

[matej@viklef tmp]$ cat log
0:00:00.091283000  1412 0x9529458 WARN    GST_PLUGIN_LOADING
gstplugin.c:411:gst_plugin_load_file: module_open failed:
/usr/lib/gstreamer-0.10/libgstfaad.so: undefined symbol: faacDecDecode

(totem:1412): GStreamer-WARNING **: Failed to load plugin
'/usr/lib/gstreamer-0.10/libgstfaad.so': /usr/lib/gstreamer-0.10/libgstfaad.so:
undefined symbol: faacDecDecode
0:00:52.358746000  1411 0x98ef098 WARN              oggdemux
gstoggdemux.c:2337:gst_ogg_demux_read_chain:<oggdemux0> page is not BOS page
0:00:52.374194000  1411 0x98ef098 WARN              oggdemux
gstoggdemux.c:2333:gst_ogg_demux_read_chain:<oggdemux0> problem reading BOS
page: ret=-3
0:01:02.547722000  1411 0x9561ac0 WARN              oggdemux
gstoggdemux.c:2337:gst_ogg_demux_read_chain:<oggdemux1> page is not BOS page
0:01:02.554223000  1411 0x9561ac0 WARN              oggdemux
gstoggdemux.c:2333:gst_ogg_demux_read_chain:<oggdemux1> problem reading BOS
page: ret=-3
-----------------------------------------
(to compare perfectly working gst-launch):
[matej@viklef tmp]$ gst-launch -v playbin uri=file:///home/matej/tmp/video.ogg 

(gst-launch-0.10:2207): GStreamer-WARNING **: Failed to load plugin
'/usr/lib/gstreamer-0.10/libgstfaad.so': /usr/lib/gstreamer-0.10/libgstfaad.so:
undefined symbol: faacDecDecode
Nastavuji rouru na POZASTAVENA ...
/playbin0/decodebin0/typefind.src: caps = application/ogg
Roura se PŘEDTÁČÍ ...
/playbin0/selector_video_src0: active-pad = "sink0"
/playbin0/decodebin0/queue0.sink: caps = video/x-theora
/playbin0/decodebin0/queue0.src: caps = video/x-theora
/playbin0/decodebin0/theoradec1.sink: caps = video/x-theora
/playbin0/decodebin0/theoradec1.src: caps = video/x-raw-yuv,
format=(fourcc)I420, framerate=(fraction)10/1,
pixel-aspect-ratio=(fraction)54/59, width=(int)542, height=(int)306
/playbin0/selector_video_src0.sink0: caps = video/x-raw-yuv,
format=(fourcc)I420, framerate=(fraction)10/1,
pixel-aspect-ratio=(fraction)54/59, width=(int)542, height=(int)306
/playbin0/decodebin0.src0: caps = video/x-raw-yuv, format=(fourcc)I420,
framerate=(fraction)10/1, pixel-aspect-ratio=(fraction)54/59, width=(int)542,
height=(int)306
/playbin0/decodebin0.src0.proxypad1: caps = video/x-raw-yuv,
format=(fourcc)I420, framerate=(fraction)10/1,
pixel-aspect-ratio=(fraction)54/59, width=(int)542, height=(int)306
/playbin0/selector_video_src0.src: caps = video/x-raw-yuv, format=(fourcc)I420,
framerate=(fraction)10/1, pixel-aspect-ratio=(fraction)54/59, width=(int)542,
height=(int)306
/playbin0/preroll_video_src0.sink: caps = video/x-raw-yuv, format=(fourcc)I420,
framerate=(fraction)10/1, pixel-aspect-ratio=(fraction)54/59, width=(int)542,
height=(int)306
/playbin0/preroll_video_src0.src: caps = video/x-raw-yuv, format=(fourcc)I420,
framerate=(fraction)10/1, pixel-aspect-ratio=(fraction)54/59, width=(int)542,
height=(int)306
/playbin0/vbin/id.src: caps = video/x-raw-yuv, format=(fourcc)I420,
framerate=(fraction)10/1, pixel-aspect-ratio=(fraction)54/59, width=(int)542,
height=(int)306
/playbin0/vbin/id.sink: caps = video/x-raw-yuv, format=(fourcc)I420,
framerate=(fraction)10/1, pixel-aspect-ratio=(fraction)54/59, width=(int)542,
height=(int)306
/playbin0/vbin.sink: caps = video/x-raw-yuv, format=(fourcc)I420,
framerate=(fraction)10/1, pixel-aspect-ratio=(fraction)54/59, width=(int)542,
height=(int)306
/playbin0/vbin.sink: caps = video/x-raw-yuv, format=(fourcc)I420,
framerate=(fraction)10/1, pixel-aspect-ratio=(fraction)54/59, width=(int)542,
height=(int)306
/playbin0/vbin.sink.proxypad3: caps = video/x-raw-yuv, format=(fourcc)I420,
framerate=(fraction)10/1, pixel-aspect-ratio=(fraction)54/59, width=(int)542,
height=(int)306
/playbin0/vbin/vconv.src: caps = video/x-raw-yuv, format=(fourcc)I420,
framerate=(fraction)10/1, pixel-aspect-ratio=(fraction)54/59, width=(int)542,
height=(int)306
/playbin0/vbin/vconv.sink: caps = video/x-raw-yuv, format=(fourcc)I420,
framerate=(fraction)10/1, pixel-aspect-ratio=(fraction)54/59, width=(int)542,
height=(int)306
/playbin0/vbin/vscale.src: caps = video/x-raw-yuv, format=(fourcc)I420,
framerate=(fraction)10/1, pixel-aspect-ratio=(fraction)54/59, width=(int)542,
height=(int)306
/playbin0/vbin/vscale.sink: caps = video/x-raw-yuv, format=(fourcc)I420,
framerate=(fraction)10/1, pixel-aspect-ratio=(fraction)54/59, width=(int)542,
height=(int)306
/playbin0/vbin/videosink/videosink-actual-sink.sink: caps = video/x-raw-yuv,
format=(fourcc)I420, framerate=(fraction)10/1,
pixel-aspect-ratio=(fraction)54/59, width=(int)542, height=(int)306
/playbin0/vbin/videosink.sink: caps = video/x-raw-yuv, format=(fourcc)I420,
framerate=(fraction)10/1, pixel-aspect-ratio=(fraction)54/59, width=(int)542,
height=(int)306
/playbin0/vbin/videosink.sink: caps = video/x-raw-yuv, format=(fourcc)I420,
framerate=(fraction)10/1, pixel-aspect-ratio=(fraction)54/59, width=(int)542,
height=(int)306
/playbin0/vbin/videosink.sink.proxypad2: caps = video/x-raw-yuv,
format=(fourcc)I420, framerate=(fraction)10/1,
pixel-aspect-ratio=(fraction)54/59, width=(int)542, height=(int)306
Roura je PŘEDTOČENA ...
Nastavuji rouro na PŘEHRÁVÁ ...
New clock: GstSystemClock
Dostal jsem EOS od elementu "playbin0".
Execution ended after 9800010000 ns.
Nastavuji rouru na POZASTAVENA ...
Nastavuji rouru na PŘIPRAVENA ...
/playbin0/vbin/videosink/videosink-actual-sink.sink: caps = NULL
/playbin0/vbin/videosink.sink: caps = NULL
/playbin0/vbin/vscale.src: caps = NULL
/playbin0/vbin/vscale.sink: caps = NULL
/playbin0/vbin/vconv.src: caps = NULL
/playbin0/vbin/vconv.sink: caps = NULL
/playbin0/vbin/id.src: caps = NULL
/playbin0/vbin/id.sink: caps = NULL
/playbin0/vbin.sink: caps = NULL
/playbin0/preroll_video_src0.src: caps = NULL
/playbin0/preroll_video_src0.sink: caps = NULL
/playbin0/selector_video_src0.sink0: caps = NULL
/playbin0/selector_video_src0.src: caps = NULL
/playbin0/decodebin0.src0: caps = NULL
/playbin0/decodebin0/theoradec1.src: caps = NULL
/playbin0/decodebin0/theoradec1.sink: caps = NULL
/playbin0/decodebin0/queue0.src: caps = NULL
/playbin0/decodebin0/queue0.sink: caps = NULL
/playbin0/decodebin0/oggdemux0.serial_388932d4: caps = NULL
/playbin0/decodebin0/typefind.src: caps = NULL
Nastavuji rouru na NULL ...
UVOLŇUJI rouru ...
[matej@viklef tmp]$
Comment 1 Bastien Nocera 2008-03-28 07:51:25 EDT
You'll need to increase the debug for the totem log (GST_DEBUG=*:5) , because
there's nothing to see in between 00:00 and 00:52. You'll probably need to gzip
the log as well.

Could you also please make sure you post logs in English, and not in Czech...
Comment 2 Matěj Cepl 2008-05-21 01:06:44 EDT
Cannot reproduce the problem anymore with totem-2.23.2-2.fc9.i386 and
gstreamer-plugins-base-0.10.19-2.fc9.i386. Feel free to close this bug.
Comment 3 Bastien Nocera 2008-05-21 04:18:17 EDT
Cool.

Note You need to log in before you can comment on or make changes to this bug.