This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 436290 - getaddrinfo return only IPv4 Address
getaddrinfo return only IPv4 Address
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
: 436289 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-06 07:23 EST by Jean-Jacques Sarton
Modified: 2008-03-11 05:11 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-11 05:11:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jean-Jacques Sarton 2008-03-06 07:23:39 EST
Description of problem:
If hints.ai_family is set to AF_UNSPEC or if hints is NULL only, no records with
IPv6 (AF_INET6) are returned into the result

Version-Release number of selected component (if applicable):
glibc-2.7-2

How reproducible:
query simply via getaddrinfo, with above settings for host with IPc6 addresses

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
getaddrinfo() shall first look for AAAA records and then for A records.

Additional info:
Comment 1 Jakub Jelinek 2008-03-06 07:41:24 EST
*** Bug 436289 has been marked as a duplicate of this bug. ***
Comment 2 Jean-Jacques Sarton 2008-03-06 10:51:20 EST
The file /etc/nsswitch was not OK, it contained only file for the network: entry.
For programs as firefox, ftp, ssh, ... all worked fine as well for external as for
internal addresses,
After inserting of dns after file, all seen to work 

Note You need to log in before you can comment on or make changes to this bug.