Bug 436350 - WEP does not work ("link is not ready")
WEP does not work ("link is not ready")
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-06 13:00 EST by Gene Czarcinski
Modified: 2008-03-11 10:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-11 10:27:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages (47.62 KB, text/plain)
2008-03-07 11:42 EST, Gene Czarcinski
no flags Details
lspci (1.80 KB, text/plain)
2008-03-07 11:42 EST, Gene Czarcinski
no flags Details
lspci -n (714 bytes, text/plain)
2008-03-07 11:43 EST, Gene Czarcinski
no flags Details
iwconfig wlan0 (469 bytes, text/plain)
2008-03-07 11:43 EST, Gene Czarcinski
no flags Details
iwlist wlan0 scan (3.33 KB, text/plain)
2008-03-07 11:44 EST, Gene Czarcinski
no flags Details
iwconfig wlan1 (469 bytes, text/plain)
2008-03-07 11:45 EST, Gene Czarcinski
no flags Details
iwlist wlan1 scan (1.12 KB, text/plain)
2008-03-07 11:45 EST, Gene Czarcinski
no flags Details

  None (edit)
Description Gene Czarcinski 2008-03-06 13:00:43 EST
Description of problem:
I am having a very difficult time trying to get wireless to work with WEP enabled.

Version-Release number of selected component (if applicable):
Fedora 8 more or less "current"

How reproducible:
every time

The system is a Compaq R3000z with Fedora 8 32-bit (i386) fresh installed and
updated.  This laptop has a built in wireless interface of a Broadcom BCM4306. 
In addition, I have tried a Linksys WAP11 PCMCIA card (11b) and a Linksys
WPC55AG PCMCIA card.  Nothing works on Fedora 8.

I have installed the firmware broadcom-wl-4.80.53.0.tar.bz2 with b43-fwcutter.

Interestly, I have another laptop .. an old Compaq 2700 with Fedora Core 1
installed.  The WAP11 card works fine with WEP.

I have attempted using s-c-network, manual command-line commands, and
NetworkManager to configure and control things ... the results are the same ...
does not work. (no commo).  A message in /var/log/messages says "link is not ready".

The Access Point running WEB is a Linksys WAP54G (supports B+G).  There are a
number of systems running Windows XP which have no problems connecting to the
WEP AP ... including the R3000Z since it is dual-boot.  On the R3000z, all of
the wireless interfaces above work under XP.

The network has a second Access Point ... Linksys WRT54G configured with no
security (WEP or WPA) except MAC address filtering.  All of the interfaces on
the R3000z work fine connecting to the non-WEP AP.

I have searched bugzilla (under Fedora).  I have searched the Fedora, devel, and
test mailing lists.  I have googled the Internet.  There is very little out
there ... some "complaints" that it does not work but not many.  There were some
suggestions (e.g, use command line configuration) which I tried but without success.

Although I am reporting this against the kernel, I am not sure that this is a
kernel problem.

At this point, I am not sure if this is something stupid on my part or truely a
bug.  If this really is a bug, then I believe that very few people try to use
WEP on any Fedora system. (Yes, I know WPA is better and I sould be using that
but for other reasons I need to keep the WEP interface).

BTW, I mentioned that the WAP11 works under Fedora Core 1.  I did run across a
message (somewhere) which stated that WEP worked fine until some point in FC6
updates.  With the initial install of FC6, it worked but then stopped working
after some update.  I also ran across a comment that a version WEP stopped
working in a Slackware update (new version) and, if the wireless-tools from the
prvious version was installed, WEP worked again.

Rather than add/attach a whole bunch of config files, logs, outputs of commnds,
etc. all of which may be useless, tell me what you need.
Comment 1 John W. Linville 2008-03-07 08:20:49 EST
The "link is not ready" is expected and unimportant enough that we should 
probably find a way to prevent it from showing-up. :-(

Please attach the contents of /var/log/messages, as well as the output of 
running 'lspci -n', 'iwlist wlan0 scan', and 'iwconfig wlan0'.  Hopefully that 
will give us sufficient info to begin narrowing the search...thanks!
Comment 2 Gene Czarcinski 2008-03-07 11:41:11 EST
Attachments follow.

I did a fresh bootup and edited the /var/liog/messages to only have this bootup.

I I two interfaces configured identically .. the internal Broadcom BCM4306 and
the Linksys WPC55AG PC card.  I have redacted the key from the iwconfig listing
files.

Both interfaces are configured to use dhcp.  After the final failuse of the
Broadcom, the interface was disabled and I re-did deactive/active wlan0 so that
I could run iwlist wlan0 scan while the interface was enabled for dhcp tries. 
The Linksys stayed enabled after failure so iwlist work during and after.
Comment 3 Gene Czarcinski 2008-03-07 11:42:09 EST
Created attachment 297206 [details]
/var/log/messages
Comment 4 Gene Czarcinski 2008-03-07 11:42:41 EST
Created attachment 297207 [details]
lspci
Comment 5 Gene Czarcinski 2008-03-07 11:43:06 EST
Created attachment 297208 [details]
lspci -n
Comment 6 Gene Czarcinski 2008-03-07 11:43:56 EST
Created attachment 297209 [details]
iwconfig wlan0

Internal Broadcom BCM4306
Comment 7 Gene Czarcinski 2008-03-07 11:44:27 EST
Created attachment 297210 [details]
iwlist wlan0 scan
Comment 8 Gene Czarcinski 2008-03-07 11:45:04 EST
Created attachment 297212 [details]
iwconfig wlan1

Linksys WPC55AG
Comment 9 Gene Czarcinski 2008-03-07 11:45:49 EST
Created attachment 297213 [details]
iwlist wlan1 scan
Comment 10 Gene Czarcinski 2008-03-07 11:48:06 EST
both interfaces work with the "winchester97" unencrypted AP.
Comment 11 Gene Czarcinski 2008-03-09 12:08:14 EDT
Just for the hell of it, I consigured a Linksys WRT54G to use WPA-Personal.  I
then (using NetwortManager) connect to it with no (NO!) problem.

Unfortunately, my situation is that I have a two segment network with the two
wired segments connected via 54G wireless.  On the one segment (the segment
actually connected via a firewall to the Internet), I have a WAP54G running WEP
... why WEP instead of WPA ... the other wire segment has a WET54G "bridge"
which is only capable of no security or WEP.  I cannot find a commercial product
which supports bridging into a 54G WPA netowrk.
Comment 12 John W. Linville 2008-03-10 10:24:13 EDT
Is "JruQNcb8DN6Y" your WEP AP?  Or is it one of the other ones?

FWIW, I use WEP nearly every day on a variety of hardware.  It is a very 
simple protocol, so I am surprised you would be having any trouble with it.

How are you configuring your wireless network?  NetworkManager?  
system-config-network?  Or manually (i.e. iwlist, iwconfig)?  If the latter, 
what is the exact sequence you are using?
Comment 13 Gene Czarcinski 2008-03-10 16:57:36 EDT
1. Yes, "JruQNcb8DN6Y" is my WEP AP ... yes, I named it before I realized that
these names were quite visible ... I really should change it except that
everything works right now (except for Fedora).  This was originally
implemented/configured in the Fedora Core 1 timeframe.

2. I have tried using s-c-network, NetworkManager, and command-line (iwconfig,
etc.) to configure/control the network interface with WEP and they all result in
the same thing ... it does not work.  I fully believe that it is some
configuration stupidity on my part but have not got a clue as to where the error
is.  I would prefer to use s-c-network or NetworkManager as oppose to command-line.

3.  Not wanting to screw with the existing hardware/configurations since I need
it to work to support some systems, I decided to get another AP to see if
un-encrypted worked for me ... it turns out that Best Buy is running a fire-sale
right now on the Linksys WRT54G ($45) so I got one.

I configured the WRT54G up unencrypted with MAC filtering and tried it with
Windows-XP and Fedora 8 (with the various interfaces including the Broadcom
BCM4306) ... it worked fine [NetworkManager is nice].   Mmmmm ... lets try
WPA-Personal.  Wow, that works too with both Windows-XP and Fedora 8 (using
NetworkManager) [I have no idea how to configure it with s-c-network].  Not only
did it work but it appears to work better than the old stuff (stronger signal
and faster).

This worked so well that I bought a second WRT54G (at $45, why not) and got a
copy of dd-wrt ... I am in the process of setting this second WRT54G up as a
client-bridge for the lan segment that currently uses a WET54G (which does not
support WPA and actually costs more ... $100).

To be blunt, I got tied of beating my head against the wall and tried someting
different which seems to work (both better and with better security).  Once I
get everything working to my satisfaction, I intend to replace the old WEP based
wireless with this new WPA based wireless.

That said, the WEP based stuff is there (and can stay in place for a while) and
I am willing to debug things (I really would like to know why it does not work
and I have the time to support it) ... if it is a configuration error on my
part, then maybe it will help someone else; if it is a "bug", then maybe it can
be identified and fixed.  But, my need to have it work has greatly reduced.

It is up to you ... If you have a lot of other high priority work, then bag it.
 If you can spend some time figuring this out with me then great, lets continue.
Comment 14 John W. Linville 2008-03-10 17:08:04 EDT
WEP should definitely work, so it iw probably worth figuring-out what might be 
happening...

IIRC, switching from WPA to WEP on the wrt54g is pretty simple.  Did you 
happen to try a WEP configuration with the new AP?  Stick with 
NetworkManager -- since that was working for you with WPA, it should work w/ 
WEP too.  If not, then please attach a new copy of /var/log/messages, one 
taken after you have tried to connect w/ WEP using NetworkManager.  Sometimes 
that gives more information...thanks!

Comment 15 Gene Czarcinski 2008-03-11 08:45:36 EDT
OK, I will run the WEP test with the WRT54G later today.

Right now I suspect that the problem is the WAP54G box/firmware.  This an early
box as there is no version specified on the external label and the firmware is V
1.06 dated Feb 2003.  Unfortunately, I need it to support what it currently
supports and did not want to screw with it (e.g., screw it up so supported stuff
does not work).
Comment 16 Gene Czarcinski 2008-03-11 10:27:35 EDT
OK, I just ran a "quick" test with WEP on the WRT54G and it did not work with my
intent to document later ...

... but, then I was "fooling" around with both the WPA1 and WEP (production) APs
working.  I tried to connect using NetworkManager to the WEP AP ("JruQNcb8DN6Y")
... son of a gun ... it WORKED!!!

I have no idea what I did to make it work but it is working (no updates applied
for the last few days).

I reran the test using s-c-network and it did not work (??)  Since
NetworkManager does work, that is good enough.

I am closing this NOTABUG

Note You need to log in before you can comment on or make changes to this bug.