Bug 436353 - sr# 1787506 : gnome-terminal/ --full-screen option does not work
sr# 1787506 : gnome-terminal/ --full-screen option does not work
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gnome-terminal (Show other bugs)
5.1
All Linux
medium Severity medium
: rc
: ---
Assigned To: Behdad Esfahbod
desktop-bugs@redhat.com
:
Depends On:
Blocks: 391501
  Show dependency treegraph
 
Reported: 2008-03-06 13:14 EST by Alan Matsuoka
Modified: 2013-04-12 15:35 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-01 12:07:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tcpdump (176.64 KB, application/x-extension-tcpdump)
2008-03-06 13:14 EST, Alan Matsuoka
no flags Details
strace (275.87 KB, application/x-gzip)
2008-03-06 13:16 EST, Alan Matsuoka
no flags Details
screenshot (87.86 KB, image/png)
2008-03-06 13:16 EST, Alan Matsuoka
no flags Details
gdb stacktrace (6.79 KB, application/octet-stream)
2008-03-06 13:17 EST, Alan Matsuoka
no flags Details

  None (edit)
Description Alan Matsuoka 2008-03-06 13:14:08 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Alan Matsuoka 2008-03-06 13:14:08 EST
Created attachment 297078 [details]
tcpdump
Comment 2 Alan Matsuoka 2008-03-06 13:15:38 EST
Description of problem:

$ gnome-terminal  --full-screen

New terminal doe not start in fullscreens.

How reproducible:
always.

Steps to Reproduce:
1. Run "$ gnome-terminal  --full-screen"

Actual results:
New terminal doe not start in fullscreens.

Expected results:
New terminal should start in fullscreens.

Additional info:
Upstream bug:
http://bugzilla.gno me.org/show_bug.cgi?id=500092


hmmm, i hit this issue when i run gnome-terminal from xterm

 $ gnome-terminal --full-screen

If i run the command from gnome-terminal, g-t flickers a bit and ends in full
screen on the first run. On subsequent run, full screen does not work .
Comment 3 Alan Matsuoka 2008-03-06 13:16:32 EST
Created attachment 297081 [details]
strace
Comment 4 Alan Matsuoka 2008-03-06 13:16:57 EST
Created attachment 297083 [details]
screenshot
Comment 5 Alan Matsuoka 2008-03-06 13:17:19 EST
Created attachment 297084 [details]
gdb stacktrace
Comment 6 Alan Matsuoka 2008-05-09 11:21:39 EDT
This should be IT 143812.
Comment 7 RHEL Product and Program Management 2008-06-02 16:15:14 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 8 Issue Tracker 2008-06-06 17:35:48 EDT
This issue is fixed with 
http://bugzilla.gnome.org/show_bug.cgi?id=536639

Regards
Vinu


This event sent from IssueTracker by vkanakas 
 issue 143812
Comment 16 Satyabrata Maitra 2008-09-19 05:25:35 EDT
Tested this bug in RHEL5.2 Server, on i386 and x86_64 Arch so far!

Component Version tested : gnome-terminal-2.16.0-5.el5

Observation :- 

In i386 Architecture, its fixed. Tried 6 times to reproduced with the proposed rpm of the component mentioned here. But Its not reproducing there in i386.

It behaving strangely and reproducing randomly in x86_64 Architecture with the same version of the component. Sometimes opening new terminal in full-screen mode and sometimes in normal mode!

Bug is not fully fixed yet, I think.
Comment 17 Behdad Esfahbod 2008-09-19 16:27:22 EDT
I find it hard to believe that it's fixed on one arch and not on another.  Make sure you close all gnome-terminal instances and open again, otherwise the new terminal will not be running.  Worst case, a restart may be tried.
Comment 20 errata-xmlrpc 2008-10-01 12:07:36 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0914.html

Note You need to log in before you can comment on or make changes to this bug.