Bug 436409 - Can't open a link in firefox between X screens
Summary: Can't open a link in firefox between X screens
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox   
(Show other bugs)
Version: 8
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-03-06 23:27 UTC by Matt Hirsch
Modified: 2018-04-11 06:54 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-07 15:43:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 319965 None None None Never

Description Matt Hirsch 2008-03-06 23:27:03 UTC
Description of problem:
I have firefox running on one X screeen (screen 1). If I attempt to open a link
from a gnome application on a different screen (screen 0, for example) I get a
message in a popup dialog box that says "Firefox is already running, but is not
responding. To open a new window, you must first close the existing Firefox
process, or restart your system."

Version-Release number of selected component (if applicable):
firefox-2.0.0.12-1.fc8

How reproducible:
always

Steps to Reproduce:
1. Click on a link in evolution, or right click a link in gnome-terminal and
select "open link"
  
Actual results:
The above error message is displayed.

Expected results:
The link should open in firefox.

Additional info:
The workaround is to paste the link into firefox (kind of annoying). I'm using
multiple screens without Xinerama because I want to have one rotated, and use
compiz at the same time. By the way, the same message is displayed if you try to
open a firefox window on more than one screen at a time.


Note You need to log in before you can comment on or make changes to this bug.