Bug 436442 - kaffeine update breaks yum update
kaffeine update breaks yum update
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kaffeine (Show other bugs)
7
All Linux
urgent Severity high
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-07 02:44 EST by Alex Lancaster
Modified: 2008-03-13 03:45 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.1.10.1-1.fc7.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-13 03:40:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Lancaster 2008-03-07 02:44:34 EST
This update:

https://admin.fedoraproject.org/updates/F7/FEDORA-2008-1980

causes broken deps:

sudo yum --exclude=kernel* update 
Loading "allowdowngrade" plugin
Loading "protectbase" plugin
Loading "changelog" plugin
Loading "priorities" plugin
Loading "downloadonly" plugin
Loading "fastestmirror" plugin
Loading "skip-broken" plugin
Loading "tsflags" plugin
Loading mirror speeds from cached hostfile
 * livna: livna.cat.pdx.edu
 * fedora: download.fedora.redhat.com
 * suspend2: mhensler.de
 * adobe-linux-i386: linuxdownload.adobe.com
 * updates: download.fedora.redhat.com
 * moertel-community: community.moertel.com
livna                     100% |=========================| 2.1 kB    00:00     
fedora                    100% |=========================| 2.1 kB    00:00     
suspend2                  100% |=========================|  951 B    00:00     
primary.xml.gz            100% |=========================|  12 kB    00:00     
adobe-linux-i386          100% |=========================|  951 B    00:00     
primary.xml.gz            100% |=========================|  10 kB    00:00     
updates                   100% |=========================| 2.3 kB    00:00     
moertel-community         100% |=========================|  951 B    00:00     
primary.xml.gz            100% |=========================| 6.9 kB    00:00     
Excluding Packages in global exclude list
Finished
0 packages excluded due to repository protections
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package krb5-libs.i386 0:1.6.1-8.fc7 set to be updated
---> Package krb5-workstation.i386 0:1.6.1-8.fc7 set to be updated
---> Package ghostscript-gtk.i386 0:8.15.4-4.fc7 set to be updated
---> Package ruby-mechanize.noarch 0:0.7.1-1.fc7 set to be updated
---> Package evolution.i386 0:2.10.3-8.fc7 set to be updated
---> Package akode-pulseaudio.i386 0:2.0.2-4.fc7 set to be updated
---> Package shorewall-perl.noarch 0:4.0.9-1.fc7 set to be updated
---> Package mediawiki.i386 0:1.10.4-38.fc7 set to be updated
---> Package shorewall.noarch 0:4.0.9-1.fc7 set to be updated
---> Package kdelibs-devel.i386 6:3.5.9-4.fc7 set to be updated
---> Package akode.i386 0:2.0.2-4.fc7 set to be updated
---> Package pcre-devel.i386 0:7.3-3.fc7 set to be updated
---> Package kdelibs.i386 6:3.5.9-4.fc7 set to be updated
---> Package ghostscript.i386 0:8.15.4-4.fc7 set to be updated
---> Package shorewall-shell.noarch 0:4.0.9-1.fc7 set to be updated
---> Package krb5-devel.i386 0:1.6.1-8.fc7 set to be updated
---> Package tzdata.noarch 0:2007k-2.fc7 set to be updated
---> Package kaffeine.i386 0:0.8.6-1.fc7 set to be updated
---> Package pcre.i386 0:7.3-3.fc7 set to be updated
---> Package shorewall-common.noarch 0:4.0.9-1.fc7 set to be updated
---> Package kaffeine-devel.i386 0:0.8.6-1.fc7 set to be updated
--> Processing Dependency: kaffeine-libs = 0.8.6-1.fc7 for package: kaffeine-devel
--> Finished Dependency Resolution
Error: Missing Dependency: kaffeine-libs = 0.8.6-1.fc7 is needed by package
kaffeine-devel

It appears that something is up with the Requires: kaffeine-libs in this update:

http://cvs.fedoraproject.org/viewcvs/rpms/kaffeine/F-7/kaffeine.spec?r1=1.5&r2=1.6
Comment 1 Alex Lancaster 2008-03-07 02:52:56 EST
The error appears to be that the devel package depends on a new kaffeine-libs
package:

%package devel
Summary: Development files for %{name}
Group:   Development/Libraries
Requires: %{name}-libs = %{version}-%{release}
Requires: kdelibs3-devel

but the -libs subpackage is specifically only enabled on F-8 and later:

%if 0%{?fedora} > 7
# make -libs subpkg
%define libs 1
%endif
  	 
Comment 2 Rex Dieter 2008-03-07 08:52:38 EST
The main pkg also includes:
Provides:  %{name}-libs = %{version}-%{release}

Fwiw, the upgrade worked for me:
$rpm -q yum
yum-3.2.8-2.fc7.noarch
Comment 3 Rex Dieter 2008-03-07 09:13:03 EST
Nevermind, I see the same error too (I didn't have -devel installed before).
Comment 4 Rex Dieter 2008-03-07 09:17:56 EST
Looks like I messed up the logic real good there.

Quick-n-dirty fix:
rpm -e kaffeine-devel
Comment 5 Dmitry Butskoy 2008-03-07 09:34:42 EST
Such kind of bugs also prevents site-local repositories to be properly updated
automatically (i.e. "yum --downloadonly update" etc.). Including security
updates of the other packages...
Comment 6 Fedora Update System 2008-03-07 10:41:30 EST
kaffeine-0.8.6-3.fc8 has been submitted as an update for Fedora 8
Comment 7 Fedora Update System 2008-03-07 11:00:23 EST
kaffeine-0.8.6-3.fc7 has been submitted as an update for Fedora 7
Comment 8 Fedora Update System 2008-03-13 03:40:48 EDT
xine-lib-1.1.10.1-1.fc7.1, kaffeine-0.8.6-3.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2008-03-13 03:45:04 EDT
kaffeine-0.8.6-3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.