Bug 436451 - kernel-2.6.24.3-12.fc8 won't boot
kernel-2.6.24.3-12.fc8 won't boot
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-07 04:56 EST by Christoph Maser
Modified: 2008-05-14 22:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-14 22:22:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Christoph Maser 2008-03-07 04:56:58 EST
Just installed kernel-2.6.24.3-12.fc8 from updates repo and it won't boot. It
simply stops after grub before "starting nash"

Machine is an HP dc7800p
Comment 1 Remy Maucherat 2008-03-07 06:56:44 EST
On this new kernel, I get "pnpacpi: exceeded the max number of mem resources:
12" on boot, then it is highly unstable.
Comment 2 David 2008-03-07 23:44:27 EST
I also am getting this "pnpacpi: exceeded the max number of mem resources: 12"
on boot up, but it seems stable.

However this is on the plain 32 bit kernel.....  So seems all kernels are effected
Comment 3 Martin Cook 2008-03-08 05:46:06 EST
I've got the same bug. Kernel 2.6.23.15-137.fc8 works fine but 2.6.24.3-12.fc8
hangs on boot. Mostly it hangs at 'Starting anacron:' but once I got through to
the log in screen and it hung after I entered the password. When the computer
hangs, the circles continue to swirl around the cursor but nothing happens. I
can still move the cursor.

I'm using a Dell Inspiron 1721 with an AMD Turion 64 processor, and can still
log in to the terminal. I also get "pnpacpi: exceeded the max number of mem
resources: 12".
Comment 4 Edward Karavakis 2008-03-08 07:44:44 EST
The new kernel won't boot on a sony vaio laptop. see also bug #432477
Comment 5 ebordin 2008-03-10 03:42:35 EDT
I am getting this bug as well, similar to comment #3. I have had hangs at
anacron, as well as at the login screen, but my cursor freezes entirely.
Sometimes the caps lock key flashes to indicate kernel panic. I have managed to
login occasionally, but NetworkManager will not work, and launching anything
from the gnome panel fails. Trying to log out also fails, I have to hard reset.

I have a pentium 4 processor, a nvidia video card with a livna driver, and an
Ra2500 wireless card. I cannot use the previous kernel due to my video drivers.
Comment 6 Mathias Hellevang 2008-03-10 04:01:08 EDT
This bug is present on my system as well, same symptoms as #3 and #5. My system
is a Asus P5N-E SLI motherboard with a Core 2 Quad Q6600 processor, a nvidia
graphics  card. My wifi uses the RaLink RT2561/RT61 chipset.
Comment 7 Dave Pawson 2008-03-10 08:49:23 EDT
Same problem. After help from #fedora on irc I found
http://forums.fedoraforum.org/showpost.php?p=5538
resolved it. 

Wouldn't get as far as grub phase 2. 


The above link resolved it, further livna updates cleared the nvidia issue.

Bad / insuffient testing? Dunno. 

I'll be far more cautious updating in future if they aren't to be trusted.


Comment 8 Nigel Barnfield 2008-03-11 17:45:43 EDT
I'm getting boot failures too on an Asus P5W DH Deluxe motherboard on Fedora 8
I normally boot with irqpoll, due to my jmicron controller, and when booting, I
get the following

ATA 8:00 Status {DRDY}
Buffer I/O error on sdb1
Failed revalidation

This comes up about 10-20 times, and then the machine freezes once I get to the
X screen. 
2.6.23.15-137 works fine 

Comment 9 George 2008-03-15 06:32:43 EDT
on Comment #8 
for a test: try adding pci=nomsi to kernel parameters.
Comment 10 Christoph Maser 2008-03-17 03:03:26 EDT
Same problem with kernel-2.6.24.3-34.fc8. After some time (1-2 Minutes) I get:

Kernel panic - not syncing: DMAR hardware is malfunctioning.
Comment 11 Erich Schroeder 2008-03-17 18:04:12 EDT
I get the same problem with both kernel-2.6.24.3-12 & -34 on my ACER Travelmate
450LMi. I don't see the Kernel panic message, but after some time during the HAL
portion of bootup the full GDM window does eventually come up, but there is no
response to keyboard or touchpad.

kernel-2.6.23.15-137 is still fully operational.
Comment 12 Erich Schroeder 2008-03-17 18:05:15 EDT
Oops, that's Travelmate 4502LMi.
Comment 13 Chuck Ebbert 2008-03-18 10:57:00 EDT
(In reply to comment #10)
> Same problem with kernel-2.6.24.3-34.fc8. After some time (1-2 Minutes) I get:
> 
> Kernel panic - not syncing: DMAR hardware is malfunctioning.

That is bug 436899.
Comment 14 Erich Schroeder 2008-03-27 16:47:43 EDT
Ok, I am now running 2.6.24-3-50 and am getting the same result on the Acer
travelmate. Good looking boot up until a very long pause at the HAL daemon start
up. Eventually the GDM login screen comes up, but neither the touchpad nor the
keyboard have any response. This time I decided to try plugging in a USB
keyboard & wireless mouse, and they work! I thought I'd try running smolt to
send up a profile but I get the following:

[root@froinleven ~]# smoltSendProfile 
Traceback (most recent call last):
  File "/usr/bin/smoltSendProfile", line 35, in <module>
    from scan import scan, rating
  File "/usr/share/smolt/client/scan.py", line 30, in <module>
    h = smolt.Hardware()
  File "/usr/share/smolt/client/smolt.py", line 342, in __init__
    raise SystemBusError, _('Could not connect to hal, is it running?\nRun
"service haldaemon start" as root')
smolt.SystemBusError: Could not connect to hal, is it running?
Run "service haldaemon start" as root
[root@froinleven ~]# service haldaemon start
Starting HAL daemon: 
[root@froinleven ~]# service haldaemon status
hald (pid 2421) is running...
[root@froinleven ~]# smoltSendProfile 
Traceback (most recent call last):
  File "/usr/bin/smoltSendProfile", line 35, in <module>
    from scan import scan, rating
  File "/usr/share/smolt/client/scan.py", line 30, in <module>
    h = smolt.Hardware()
  File "/usr/share/smolt/client/smolt.py", line 342, in __init__
    raise SystemBusError, _('Could not connect to hal, is it running?\nRun
"service haldaemon start" as root')
smolt.SystemBusError: Could not connect to hal, is it running?
Run "service haldaemon start" as root
[root@froinleven ~]# service haldaemon status
hald (pid 2421) is running...
[root@froinleven ~]# 

Any of this help, or am I now the only one having this problem?
Comment 15 Chuck Ebbert 2008-04-18 16:57:11 EDT
(In reply to comment #11)
> I get the same problem with both kernel-2.6.24.3-12 & -34 on my ACER Travelmate
> 450LMi. I don't see the Kernel panic message, but after some time during the HAL
> portion of bootup the full GDM window does eventually come up, but there is no
> response to keyboard or touchpad.
> 
> kernel-2.6.23.15-137 is still fully operational.

After plugging in a usb keybaord, can you post the contents of the system log
from bottup until you add the keybord?
Comment 16 Christoph Maser 2008-05-13 13:22:26 EDT
For me the topic is done. This is a duplicate of 436899. There is a lot of other
stuff here which has nothing to do with my bug so i'm not closing this. The
maintainers should decide what to do with this bug.
Comment 17 Chuck Ebbert 2008-05-14 22:22:12 EDT
Closing as notabug since the hardware from the original report is broken. All
the people who piled on had different bugs, mostly ralink wireless hardware
problems which are fixed now.

Note You need to log in before you can comment on or make changes to this bug.