Bug 436463 - Build problems on ppcp arch (64bit)
Build problems on ppcp arch (64bit)
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: tomcat5 (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: David Knox
tomcat-qe
:
: 460119 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-07 07:35 EST by Martin Kočí
Modified: 2015-11-01 19:15 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:18:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Build log from ppcp server (2.01 MB, text/plain)
2008-03-07 07:35 EST, Martin Kočí
no flags Details

  None (edit)
Description Martin Kočí 2008-03-07 07:35:50 EST
Description of problem:
I got an errors with building on ppcp(64bit) (seems to have problems with
lib/lib64 directory). Truncated error log :
...
Processing files: tomcat5-5.5.23-0jpp.3.0.3.el5_1
error: File not found by glob:
/var/tmp/tomcat5-0-5.5.23-0jpp.3.0.3.el5_1-root/usr/lib/gcj/tomcat5/bootstrap*
error: File not found by glob:
/var/tmp/tomcat5-0-5.5.23-0jpp.3.0.3.el5_1-root/usr/lib/gcj/tomcat5/commons-daemon*
...
Processing files: tomcat5-webapps-5.5.23-0jpp.3.0.3.el5_1
error: File not found by glob:
/var/tmp/tomcat5-0-5.5.23-0jpp.3.0.3.el5_1-root/usr/lib/gcj/tomcat5/catalina-root*
Processing files: tomcat5-admin-webapps-5.5.23-0jpp.3.0.3.el5_1
error: File not found by glob:
/var/tmp/tomcat5-0-5.5.23-0jpp.3.0.3.el5_1-root/usr/lib/gcj/tomcat5/catalina-admin*
...

(I have attached all build log)


Version-Release number of selected component (if applicable):
tomcat5-5.5.23-0jpp.3.0.3.el5_1.src.rpm

How reproducible:
try to build it on ppcp (64bit)

Actual results:
Build failed.

Expected results:
Build passed.

Thank You
koca
Comment 1 Martin Kočí 2008-03-07 07:35:50 EST
Created attachment 297178 [details]
Build log from ppcp server
Comment 5 Deepak Bhole 2008-08-26 15:35:59 EDT
*** Bug 460119 has been marked as a duplicate of this bug. ***
Comment 6 David Walluck 2008-08-27 15:44:21 EDT
This built for me in brew on ppc64. See <https://brewweb.devel.redhat.com/buildinfo?buildID=74312>, e.g., <http://porkchop.devel.redhat.com/brewroot/packages/tomcat5/5.5.23/0jpp.7.el5_2.1/ppc64/tomcat5-5.5.23-0jpp.7.el5_2.1.ppc64.rpm>.

I note a difference in the release for my builds (5_2 instead of 5_1), but the bug specifies 5.2 for the product version. Are we building on the same arch?

I also do not see why this is specific to tomcat5. You should experience the same for any Java package that has GCJ support enabled (e.g., any packages that reference %{_libdir}/gcj). Can you test some additional packages?
Comment 7 Martin Kočí 2008-08-29 02:25:22 EDT
 (In reply to comment #6)
AFAIK I have built it on rhel 5.2 release and arch. was ppcp64. Petr have you some experiences with any other Java package which has GCJ support (see comment #6) ?
Comment 8 Petr Šplíchal 2008-08-29 02:50:44 EDT
I have encountered the problem only with tomcat5.
(Haven't tested any other Java advisory yet...)
Comment 11 RHEL Product and Program Management 2014-03-07 07:48:46 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 12 RHEL Product and Program Management 2014-06-02 09:18:43 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.