Bug 436489 - freeipmi-bmc-watchdog install script fails
freeipmi-bmc-watchdog install script fails
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: freeipmi (Show other bugs)
5.2
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Phil Knirsch
Alexander Todorov
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-07 10:49 EST by Robert M Williams
Modified: 2015-03-04 20:19 EST (History)
3 users (show)

See Also:
Fixed In Version: RHEA-2008-0413
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:26:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
install.log from test system (130.21 KB, text/plain)
2008-03-07 10:49 EST, Robert M Williams
no flags Details

  None (edit)
Description Robert M Williams 2008-03-07 10:49:46 EST
Description of problem:
Error with installation of freeipmi-ipmidetectd

Version-Release number of selected component (if applicable):
freeipmi-ipmidetectd-0.5.1-3.el5.x86_64

How reproducible:


Steps to Reproduce:
1.perform installation of RHEL 5.2 
2.
3.
  
Actual results:
Error(s) installing: freeipmi-ipmidetectd 0.5.1 3.el5 x86_64
error: %post(freeipmi-ipmidetectd-0.5.1-3.el5.x86_64) scriptlet failed, exit
status 1
Error(s) installing: freeipmi-bmc-watchdog 0.5.1 3.el5 x86_64
/etc/rc.d/init.d/freeipmi-bmc-watchdog: line 11: /etc/rc.d/init.d/functions: No
such file or directory
/etc/rc.d/init.d/freeipmi-bmc-watchdog: line 11: /etc/rc.d/init.d/functions: No
such file or directory
error: %post(freeipmi-bmc-watchdog-0.5.1-3.el5.x86_64) scriptlet failed, exit
status 1

Expected results:


Additional info:
Comment 1 Robert M Williams 2008-03-07 10:49:46 EST
Created attachment 297193 [details]
install.log from test system
Comment 2 Robert M Williams 2008-03-07 11:03:41 EST
info in the Description and Version above are incorrect.
Updated here.

Description of problem:
Error with installation of freeipmi-bmc-watchdog

Version-Release number of selected component (if applicable):
freeipmi-bmc-watchdog-0.5.1-3.el5.x86_64
Comment 3 James Laska 2008-03-07 11:09:07 EST
Greetings Phil, 

Not sure if you wanted to track the freeipmi install.log failures separately or
all in bug#432792.  While they are all against the same src.rpm, the failure
case in this bugzilla seems slightly different.
Comment 4 Phil Knirsch 2008-03-20 10:51:26 EDT
Ouch. Now i know what the problem is. DOH!

Missing requires(pre|post) to initscripts.

I'll build new packages today and as for a need_respin once more of the errata.

Thanks for this report, this really helped a lot to nail down the problem!

Read ya, Phil

PS: Granting Devel ACK ofc.
Comment 9 errata-xmlrpc 2008-05-21 11:26:59 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2008-0413.html

Note You need to log in before you can comment on or make changes to this bug.