Bug 436517 - rdate frees address info before use.
rdate frees address info before use.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rdate (Show other bugs)
5.1
All Linux
medium Severity medium
: rc
: ---
Assigned To: Jiri Moskovcak
:
Depends On:
Blocks: 391501
  Show dependency treegraph
 
Reported: 2008-03-07 12:43 EST by Martin Poole
Modified: 2015-02-01 17:48 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2008-0613
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-23 08:56:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to move freeing of address info to after use. (1.45 KB, patch)
2008-03-07 12:43 EST, Martin Poole
no flags Details | Diff

  None (edit)
Description Martin Poole 2008-03-07 12:43:08 EST
Description of problem:

rdate frees up its host address information before it uses it. Depending on how
the allocation is going this can cause segfaults, invalid parameters being
passed to the connect, or if you're lucky it works because the memory hasn't
been overwritten yet.
 
Version-Release number of selected component (if applicable):

1.4-6

How reproducible:

Most easily seen doing

  rdate -s server.example.com

in the %post of a kickstart.


Steps to Reproduce:
1. Put an rdate -s in a %post of a kickstart.
2.
3.
  
Actual results:

Could not connect to host host.example.com Invalid argument

Expected results:

time should be set silently


Additional info:
Comment 1 Martin Poole 2008-03-07 12:43:08 EST
Created attachment 297223 [details]
patch to move freeing of address info to after use.
Comment 11 errata-xmlrpc 2008-07-23 08:56:13 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0613.html

Note You need to log in before you can comment on or make changes to this bug.