Bug 436557 - [5.2] 5.1 client kmod-xenpv-PAE fails to install on AMD 32 bit system because of a failed dependency.
[5.2] 5.1 client kmod-xenpv-PAE fails to install on AMD 32 bit system because...
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xenpv-kmod (Show other bugs)
5.2
i686 Linux
medium Severity medium
: rc
: ---
Assigned To: Don Dutile
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-07 16:44 EST by Barry Donahue
Modified: 2009-12-14 16:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-31 11:19:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Barry Donahue 2008-03-07 16:44:15 EST
Description of problem:I install the PAE kernel on the system but the kmod will
not install. I tried this after installing the PAE kernel and again after I
booted on the PAE kernel. Both fail.


Version-Release number of selected component (if applicable):
Dom0 is RHEL5.2-Server-20080306.0
Client is RHEL-5-Server/U1
kmod-xenpv-PAE-0.1-7.el5.i686.rpm
uname -a: Linux dhcp78-213.lab.boston.redhat.com 2.6.18-53.el5PAE #1 SMP Wed Oct
10 16:48:18 EDT 2007 i686 athlon i386 GNU/Linux

How reproducible:Every time on AMD.


Steps to Reproduce:
1.install the PAE kernel
2.try to install the kmod-xenpv.
3.
  
Actual results:It fails with this error: 
# rpm -ivh kmod-xenpv-PAE-0.1-7.el5.i686.rpm 
  error: Failed dependencies:
        kernel-PAE-i686 is needed by kmod-xenpv-PAE-0.1-7.el5.i686



Expected results: The rpm should install.


Additional info:
Comment 1 Don Dutile 2008-03-07 18:07:55 EST
Please run the following & post a reply:

(1) uname -a after kernel install

(2) rpm --query --qf %{ARCH} kernel

(3) rpm --query --qf
%{NAME}-%{VERSION}-%{RELEASE}"\t"%{ARCH}"\t"%{OBSOLETENAME}"\n" kernel
Comment 2 Barry Donahue 2008-03-10 08:19:54 EDT
Here 'tis
#uname -a 
Linux dhcp78-213.lab.boston.redhat.com 2.6.18-53.el5PAE #1 SMP Wed Oct 10
16:48:18 EDT 2007 i686 athlon i386 GNU/Linux

# rpm --query --qf %{ARCH} kernel
i686i686

# rpm --query --qf %{NAME}-%{VERSION}-%{RELEASE}"\t"%t"%{OBSOLETENAME}"\n" kernel
kernel-2.6.18-53.el5    i686    (none)
kernel-2.6.18-53.1.4.el5        i686    (none)
Comment 3 Don Dutile 2008-03-10 19:25:19 EDT
Try out xenpv-0.1-8.el5 in brew.
This should fix the install failure.

Please post a reply whether it does or does not.
Comment 4 Barry Donahue 2008-03-31 11:19:24 EDT
This bug has been fixed by a new spin of the package.

Note You need to log in before you can comment on or make changes to this bug.