This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 436657 - sane-backends-libs-gphoto2 broken dep: missing i386 package from x86_64 repo
sane-backends-libs-gphoto2 broken dep: missing i386 package from x86_64 repo
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: sane-backends (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On: 434604
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-08 15:44 EST by Charles R. Anderson
Modified: 2014-01-21 18:02 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-25 15:23:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles R. Anderson 2008-03-08 15:44:00 EST
sane-backends-libs-gphoto2-1.0.19-6.fc9.i386.rpm is missing from
development/x86_64/os/Packages, causing dependency errors on yum update.

+++ This bug was initially created as a clone of Bug #434604 +++

Description of problem:

"yum update" fails on sane-backends-libs-gphoto2 with "ERROR with
rpm_check_debug vs depsolve".

Version-Release number of selected component (if applicable):
yum-3.2.11-1.fc9.noarch

How reproducible:
always

Steps to Reproduce:
1. yum update

Actual results:

Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
Package sane-backends-libs-gphoto2 needs sane-backends-libs =
1.0.19-5.fc9, this is not available.
Package sane-backends-libs-gphoto2 needs sane-backends-libs =
1.0.19-5.fc9, this is not available.
Complete!


Expected results:

Either a yum dependency error before it gets to the "rpm_check_debug vs.
depsolve" phase, or properly updated packages.

Additional info:

$ rpm -qa sane\*
sane-backends-libs-1.0.19-5.fc9.x86_64
sane-backends-1.0.19-5.fc9.x86_64
sane-backends-libs-1.0.19-5.fc9.i386
sane-backends-libs-gphoto2-1.0.19-5.fc9.x86_64
sane-backends-libs-gphoto2-1.0.19-5.fc9.i386


$ rpm -Va sane\*
prelink: /usr/lib64/libsane.so.1.0.19: at least one of file's dependencies has
changed since prelinking
S.?.....    /usr/lib64/libsane.so.1.0.19
S.5....T  c /etc/sane.d/dll.conf
prelink: /usr/bin/sane-find-scanner: at least one of file's dependencies has
changed since prelinking
S.?.....    /usr/bin/sane-find-scanner
prelink: /usr/bin/scanimage: at least one of file's dependencies has changed
since prelinking
S.?.....    /usr/bin/scanimage
prelink: /usr/sbin/saned: at least one of file's dependencies has changed since
prelinking
S.?.....    /usr/sbin/saned


$ yum list sane\*
Loaded plugins: presto
Setting up and reading Presto delta metadata
No Presto metadata available for livna-development
No Presto metadata available for adobe-linux-i386
No Presto metadata available for development
Installed Packages
sane-backends.x86_64                     1.0.19-5.fc9           installed       
sane-backends-libs.x86_64                1.0.19-5.fc9           installed       
sane-backends-libs.i386                  1.0.19-5.fc9           installed       
sane-backends-libs-gphoto2.x86_64        1.0.19-5.fc9           installed       
sane-backends-libs-gphoto2.i386          1.0.19-5.fc9           installed       
Available Packages
sane-backends.x86_64                     1.0.19-6.fc9           development     
sane-backends-devel.i386                 1.0.19-6.fc9           development     
sane-backends-devel.x86_64               1.0.19-6.fc9           development     
sane-backends-libs.x86_64                1.0.19-6.fc9           development     
sane-backends-libs.i386                  1.0.19-6.fc9           development     
sane-backends-libs-gphoto2.x86_64        1.0.19-6.fc9           development     
sane-frontends.x86_64                    1.0.14-4.fc9           development

-- Additional comment from cra@wpi.edu on 2008-02-22 23:10 EST --
Created an attachment (id=295696)
output of yum -v -d10 update


-- Additional comment from cra@wpi.edu on 2008-03-08 15:12 EST --
Well, I guess this is an improvement.  Now I get a proper dependency error from
yum rather than the late "rpm_chech_debug vs. depsolve" error.  It looks like
the issue is that there is a missing i386 version of the package
sane-backends-libs-gphoto2.

If you look at the output above, I have this installed:

sane-backends-libs-gphoto2-1.0.19-5.fc9.i386

But yum list doesn't show an available 1.0.19-6.fc9.i386 version.

The master FTP site is missing the .i386 version in the x86_64 repo.


# yum  update
Loaded plugins: presto
Setting up and reading Presto delta metadata
No Presto metadata available for livna-development
No Presto metadata available for adobe-linux-i386
No Presto metadata available for development
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package sane-backends-libs.i386 0:1.0.19-6.fc9 set to be updated
---> Package kdelibs-common.x86_64 6:4.0.2-8.fc9 set to be updated
---> Package xorg-x11-server-common.x86_64 0:1.4.99.901-1.20080307.fc9 set to be
updated
---> Package python.x86_64 0:2.5.1-23.fc9 set to be updated
---> Package libstdc++-devel.x86_64 0:4.3.0-2 set to be updated
---> Package ncurses-libs.i386 0:5.6-16.20080301.fc9 set to be updated
---> Package python-libs.x86_64 0:2.5.1-23.fc9 set to be updated
---> Package ncurses-base.x86_64 0:5.6-16.20080301.fc9 set to be updated
---> Package libgcj.x86_64 0:4.3.0-2 set to be updated
---> Package libstdc++.x86_64 0:4.3.0-2 set to be updated
--> Processing Dependency: sane-backends-libs = 1.0.19-5.fc9 for package:
sane-backends-libs-gphoto2
---> Package libmtp.x86_64 0:0.2.6.1-1.fc9 set to be updated
---> Package xorg-x11-drv-nv.x86_64 0:2.1.8-1.fc9 set to be updated
---> Package sane-backends-libs.x86_64 0:1.0.19-6.fc9 set to be updated
---> Package xorg-x11-drv-openchrome.x86_64 0:0.2.901-11.fc9 set to be updated
---> Package python-libs.i386 0:2.5.1-23.fc9 set to be updated
---> Package shadow-utils.x86_64 2:4.1.0-5.fc9 set to be updated
---> Package python-fedora.noarch 0:0.2.99.2-2.fc9 set to be updated
---> Package sysvinit-tools.x86_64 0:2.86-23 set to be updated
---> Package libgcc.i386 0:4.3.0-2 set to be updated
---> Package yum-utils.noarch 0:1.1.11-5.fc9 set to be updated
---> Package python-twisted-web.x86_64 0:0.7.0-3.fc9 set to be updated
---> Package samba-client.x86_64 0:3.2.0-1.pre2.6.fc9 set to be updated
---> Package libidn.i386 0:0.6.14-6 set to be updated
---> Package kdebase-runtime.x86_64 0:4.0.2-3.fc9 set to be updated
---> Package system-config-services.noarch 0:0.99.8-1.fc9 set to be updated
---> Package kdelibs.x86_64 6:4.0.2-8.fc9 set to be updated
---> Package gnash-plugin.x86_64 0:0.8.2-1.fc9 set to be updated
---> Package gcc-c++.x86_64 0:4.3.0-2 set to be updated
---> Package event-compat-sysv.noarch 0:0.3.9-9.fc9 set to be updated
--> Processing Dependency: libwbclient.so.0()(64bit) for package: libsmbclient
--> Processing Dependency: libwbclient.so.0()(64bit) for package: samba-common
--> Processing Dependency: libwbclient.so.0()(64bit) for package: samba-client
---> Package totem.x86_64 0:2.23.0-2.fc9 set to be updated
---> Package gnash.x86_64 0:0.8.2-1.fc9 set to be updated
---> Package libmudflap.x86_64 0:4.3.0-2 set to be updated
---> Package bluez-gnome.x86_64 0:0.24-1.fc9 set to be updated
---> Package libmtp.i386 0:0.2.6.1-1.fc9 set to be updated
---> Package python-twisted-core.x86_64 0:2.5.0-4.fc9 set to be updated
---> Package rsyslog.x86_64 0:3.12.1-1.fc9 set to be updated
---> Package cpp.x86_64 0:4.3.0-2 set to be updated
---> Package libidn.x86_64 0:0.6.14-6 set to be updated
---> Package ncurses.x86_64 0:5.6-16.20080301.fc9 set to be updated
--> Processing Dependency: sane-backends-libs = 1.0.19-5.fc9 for package:
sane-backends-libs-gphoto2
---> Package libgomp.x86_64 0:4.3.0-2 set to be updated
---> Package gcc.x86_64 0:4.3.0-2 set to be updated
---> Package sane-backends-libs-gphoto2.x86_64 0:1.0.19-6.fc9 set to be updated
---> Package libtdb.x86_64 0:1.1.1-1.pre2.6.fc9 set to be updated
---> Package ncurses-libs.x86_64 0:5.6-16.20080301.fc9 set to be updated
---> Package totem-gstreamer.x86_64 0:2.23.0-2.fc9 set to be updated
---> Package libsmbclient.x86_64 0:3.2.0-1.pre2.6.fc9 set to be updated
---> Package java-1.7.0-icedtea-plugin.x86_64 0:1.7.0.0-0.29.b24.fc9 set to be
updated
---> Package gdm.x86_64 1:2.21.9-0.2008.02.29.3.fc9 set to be updated
---> Package samba-common.x86_64 0:3.2.0-1.pre2.6.fc9 set to be updated
---> Package xorg-x11-server-Xorg.x86_64 0:1.4.99.901-1.20080307.fc9 set to be
updated
---> Package libstdc++.i386 0:4.3.0-2 set to be updated
---> Package libtalloc.x86_64 0:1.2.0-1.pre2.6.fc9 set to be updated
---> Package sane-backends.x86_64 0:1.0.19-6.fc9 set to be updated
---> Package libgomp.i386 0:4.3.0-2 set to be updated
---> Package java-1.7.0-icedtea.x86_64 0:1.7.0.0-0.29.b24.fc9 set to be updated
---> Package libgnomeui.x86_64 0:2.21.93-1.fc9 set to be updated
---> Package gdm-user-switch-applet.x86_64 1:2.21.9-0.2008.02.29.3.fc9 set to be
updated
---> Package totem-mozplugin.x86_64 0:2.23.0-2.fc9 set to be updated
---> Package gtk-vnc.x86_64 0:0.3.4-1.fc9 set to be updated
---> Package man-pages.noarch 0:2.78-2.fc9 set to be updated
---> Package libgcj.i386 0:4.3.0-2 set to be updated
---> Package totem-xine.x86_64 0:2.23.0-2.fc9 set to be updated
---> Package libgcc.x86_64 0:4.3.0-2 set to be updated
---> Package libgnomeui.i386 0:2.21.93-1.fc9 set to be updated
--> Running transaction check
--> Processing Dependency: sane-backends-libs = 1.0.19-5.fc9 for package:
sane-backends-libs-gphoto2
---> Package samba-winbind.x86_64 0:3.2.0-1.pre2.6.fc9 set to be updated
--> Processing Dependency: sane-backends-libs = 1.0.19-5.fc9 for package:
sane-backends-libs-gphoto2
--> Finished Dependency Resolution
sane-backends-libs-gphoto2-1.0.19-5.fc9.i386 from installed has depsolving problems
  --> Missing Dependency: sane-backends-libs = 1.0.19-5.fc9 is needed by package
sane-backends-libs-gphoto2-1.0.19-5.fc9.i386 (installed)
sane-backends-libs-gphoto2-1.0.19-5.fc9.i386 from installed has depsolving problems
  --> Missing Dependency: sane-backends-libs = 1.0.19-5.fc9 is needed by package
sane-backends-libs-gphoto2-1.0.19-5.fc9.i386 (installed)
Error: Missing Dependency: sane-backends-libs = 1.0.19-5.fc9 is needed by
package sane-backends-libs-gphoto2-1.0.19-5.fc9.i386 (installed)
Comment 1 Nils Philippsen 2008-03-10 06:14:32 EDT
I've just kicked off the sane-backends-1.0.19-7 which contains arch specific
provides/requires which should let the compose tools pull in the required
arch-packages. Please check if this works and report back. Thanks.
Comment 2 Nils Philippsen 2008-03-10 06:15:12 EDT
* "the sane-backends-1.0.19-7 build"
Comment 3 Nils Philippsen 2008-03-10 07:18:12 EDT
Argh, the build is bitten by bug #436725. Stay tuned.
Comment 4 Nils Philippsen 2008-03-10 13:09:16 EDT
The build should be tagged any minute now. Please check if all dependencies are
found once it's available.
Comment 5 Charles R. Anderson 2008-03-13 17:48:43 EDT
-7 is in the repos correctly but yum doesn't find it for depsolving purposes. 
I'll reopen the parent of this bug.
Comment 6 Charles R. Anderson 2008-03-13 18:03:49 EDT
Actually, I was wrong.  sane-backends-libs-gphoto2.i386 is still missing from
the x86_64 repo:

# yum list sane-backends\*
Loaded plugins: presto
Setting up and reading Presto delta metadata
No Presto metadata available for livna-development
No Presto metadata available for adobe-linux-i386
No Presto metadata available for development
Installed Packages
sane-backends.x86_64                     1.0.19-5.fc9           installed       
sane-backends-libs.x86_64                1.0.19-5.fc9           installed       
sane-backends-libs.i386                  1.0.19-5.fc9           installed       
sane-backends-libs-gphoto2.i386          1.0.19-5.fc9           installed       
sane-backends-libs-gphoto2.x86_64        1.0.19-5.fc9           installed       
Available Packages
sane-backends.x86_64                     1.0.19-7.fc9           development     
sane-backends-devel.i386                 1.0.19-7.fc9           development     
sane-backends-devel.x86_64               1.0.19-7.fc9           development     
sane-backends-libs.i386                  1.0.19-7.fc9           development     
sane-backends-libs.x86_64                1.0.19-7.fc9           development     
sane-backends-libs-gphoto2.x86_64        1.0.19-7.fc9           development    
Comment 7 Nils Philippsen 2008-03-14 07:09:14 EDT
My bad, I've forgotten to to arch-based provides/requires to/on -libs-gphoto2.
Version 1.0.19-8.fc9 which contains these is building right now.
Comment 8 Nils Philippsen 2008-03-14 07:56:20 EDT
Please check if things work okay with 1.0.19-8.fc9.
Comment 9 Charles R. Anderson 2008-03-19 00:13:11 EDT
I can't check until this appears in rawhide, and so far it hasn't...
Comment 10 Charles R. Anderson 2008-03-25 15:23:43 EDT
I guess this update happened "behind my back" or I otherwise wasn't paying
attention when it went through...so since I didn't need to explicitly exclude
sane-backends*, then it must be good :-)  Oh yeah, here it is in my yum.log:

Mar 21 14:50:41 Updated: sane-backends-libs-1.0.19-8.fc9.x86_64
Mar 21 14:51:08 Updated: sane-backends-libs-gphoto2-1.0.19-8.fc9.x86_64
Mar 21 15:00:01 Updated: sane-backends-1.0.19-8.fc9.x86_64
Mar 21 15:01:07 Updated: sane-backends-libs-1.0.19-8.fc9.i386
Mar 21 15:01:07 Updated: sane-backends-libs-gphoto2-1.0.19-8.fc9.i386

So I'll close this bug now.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.