Bug 436697 - Segmentation fault when closing preference Windows
Segmentation fault when closing preference Windows
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ruby-gnome2 (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Mamoru TASAKA
Fedora Extras Quality Assurance
http://rubyforge.org/tracker/index.ph...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-09 11:45 EDT by Ludovico Fischer
Modified: 2008-07-26 02:08 EDT (History)
1 user (show)

See Also:
Fixed In Version: 0.17.0-0.1.rc1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-16 09:56:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ludovico Fischer 2008-03-09 11:45:17 EDT
Description of problem:
Each time the 'Preferences' window is closed, Alexandria crashes with a segfault.

Version-Release number of selected component (if applicable):
0.6.3-1.fc8
Steps to Reproduce:
1.Launch Alexandria. 
2.Select Edit>Preferences. 
3.Click the 'Close' button. 


  
Actual results:
Alexandria crashes.

Expected results:
The preference dialogs should close, but the application should keep running.

Terminal log:
/usr/lib/ruby/site_ruby/1.8/alexandria/ui/iconview_tooltips.rb:101: [BUG]
Segmentation fault
ruby 1.8.6 (2007-09-24) [x86_64-linux]
Comment 1 Mamoru TASAKA 2008-03-09 12:21:44 EDT
Umm.. does not happen on i386 and seemingly ruby-gnome2 bug.
What does the following say:

- Install ruby-debuginfo, ruby-gnome2-debuginfo
  (perhaps gtk2-debuginfo, glib2-debuginfo also needed and maybe more)
- Install  gdb (more debuginfo rpms maybe needed)
- gdb ruby -> run /usr/bin/alexandria
- Select Edit>Preferences, click close
- type thread apply all bt
Comment 2 Ludovico Fischer 2008-03-11 00:03:29 EDT
Mmm, I enabled all the *-debuginfo repositories, yet there are some problems
with the debugging libraries:
warning: the debug information found in
"/usr/lib/debug//usr/lib64/libruby.so.1.8.6.debug" does not match
"/usr/lib64/libruby.so.1.8" (CRC mismatch).
Also:
Error: Missing Dependency: libgiofam.so()(64bit) is needed by package
glib2-debuginfo
Error: Missing Dependency: libgio-2.0.so.0()(64bit) is needed by package
glib2-debuginfo

Shall I open another (or rather two) bug about this?

Ludovico
Comment 3 Mamoru TASAKA 2008-03-11 02:14:22 EDT
(In reply to comment #2)
> warning: the debug information found in
> "/usr/lib/debug//usr/lib64/libruby.so.1.8.6.debug" does not match
> "/usr/lib64/libruby.so.1.8" (CRC mismatch).

This usually means that the EVR (Epoch-Version-Release) of ruby(-libs)
and ruby-debuginfo mismatch.

> Also:
> Error: Missing Dependency: libgiofam.so()(64bit) is needed by package
> glib2-debuginfo
> Error: Missing Dependency: libgio-2.0.so.0()(64bit) is needed by package
> glib2-debuginfo

Do you have 64bit glib2 rpm installed? If so, I cannot figure out
what is happening...

Comment 4 Ludovico Fischer 2008-03-11 20:58:50 EDT
(In reply to comment #3)

> This usually means that the EVR (Epoch-Version-Release) of ruby(-libs)
> and ruby-debuginfo mismatch.
 Should I report this as a bug?

> Do you have 64bit glib2 rpm installed? If so, I cannot figure out
> what is happening...
I have both installed: 
$ yum list glib2
Installed Packages
glib2.x86_64                             2.14.6-1.fc8           installed       
glib2.i386                               2.14.6-1.fc8           installed       

Maybe another bug? It seems there is a problem with the *-debug repositories on
x86_64.

Ludovico
Comment 5 Mamoru TASAKA 2008-03-12 13:39:11 EDT
Well, today I got the right to access other person's x86_64 machine.
I will try to reproduce this issue on that machine (on weekend?)

(In reply to comment #4)
> (In reply to comment #3)
> 
> > This usually means that the EVR (Epoch-Version-Release) of ruby(-libs)
> > and ruby-debuginfo mismatch.
>  Should I report this as a bug?
Perhaps this usually happens (as -debuginfo rpm doesn't have
EVR specific dependency). Just checking EVR by yourself is better
(actually I have never tried to install debuginfo rpms by yum...)


> > Do you have 64bit glib2 rpm installed? If so, I cannot figure out
> > what is happening...
> I have both installed: 
> $ yum list glib2
> Installed Packages
> glib2.x86_64                             2.14.6-1.fc8           installed       
> glib2.i386                               2.14.6-1.fc8           installed       
> 
> Maybe another bug? 
It maybe or maybe not?? Perhaps installing debuginfo by rpm command
is better.
Comment 6 Mamoru TASAKA 2008-03-20 04:38:23 EDT
Umm.. I thought I could reproduce this (on x86_64), however after some
works this can no longer be reproduced to me (on x86_64), why...

Anyway can you still reproduce this?
Comment 7 Mamoru TASAKA 2008-03-23 04:16:33 EDT
Okay, reproduced.

I guess 0.6.3-2 should fix your problem.. Would you try it?
http://koji.fedoraproject.org/koji/buildinfo?buildID=43566

Also reported upstream.
http://rubyforge.org/tracker/index.php?func=detail&aid=19042&group_id=205&atid=863
Comment 8 Ludovico Fischer 2008-03-25 17:41:42 EDT
I am very sorry, but I do not have a Fedora installation available anymore. 
Comment 9 Ludovico Fischer 2008-03-25 19:36:03 EDT
> I am very sorry, but I do not have a Fedora installation available anymore. 


OK, I have a new Fedora 8 x86_64. 
"yum --nogpgcheck localinstall ~/Desktop/alexandria-0.6.3-2.fc8.noarch.rpm"
So far the bug seems to have disappeared. I can close the Preferences window
normally.
Comment 10 Mamoru TASAKA 2008-03-26 07:50:16 EDT
(In reply to comment #9)
> OK, I have a new Fedora 8 x86_64. 
> "yum --nogpgcheck localinstall ~/Desktop/alexandria-0.6.3-2.fc8.noarch.rpm"
> So far the bug seems to have disappeared. I can close the Preferences window
> normally.

Okay. Thank you for confirmation.

Comment 11 Mamoru TASAKA 2008-03-26 14:01:33 EDT
Should be fixed in 0.6.3-2.  Thank you for reporting this bug.
Comment 12 Mamoru TASAKA 2008-07-16 09:56:57 EDT
Confirmed that this was actually due to the bug in ruby-gnome2 0.16.0 and
is fixed by ruby-gnome2 0.17.0 rc1.

Changing component and re-closing.
http://bugs.gentoo.org/show_bug.cgi?id=215634
http://sourceforge.net/tracker/index.php?func=detail&aid=1930481&group_id=53614&atid=470969
Comment 13 Fedora Update System 2008-07-16 12:47:41 EDT
alexandria-0.6.3-5.fc9 has been submitted as an update for Fedora 9
Comment 14 Fedora Update System 2008-07-16 12:48:30 EDT
alexandria-0.6.3-5.fc8 has been submitted as an update for Fedora 8
Comment 15 Fedora Update System 2008-07-26 02:08:04 EDT
alexandria-0.6.3-5.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.