Bug 436700 - anaconda fails at upldate_boot_loader
anaconda fails at upldate_boot_loader
Status: CLOSED DUPLICATE of bug 241991
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
i686 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-09 12:30 EDT by Frank DiPrete
Modified: 2008-03-10 09:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-10 09:29:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda dump (64.29 KB, text/plain)
2008-03-09 14:32 EDT, Frank DiPrete
no flags Details

  None (edit)
Description Frank DiPrete 2008-03-09 12:30:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.12) Gecko/20080208 Fedora/2.0.0.12-1.fc7 Firefox/2.0.0.12

Description of problem:

trying to upgrade fc6 to fc7 using rescue cd (and ntfs).
anaconda fails at update_boot_loader (python script error, Text)


Version-Release number of selected component (if applicable):
Anaconda

How reproducible:
Always


Steps to Reproduce:
1. use fc7 rescue cd, install
2. askmethod text
3.

Actual Results:

fails at update_boot_loader

Expected Results:

no failure

Additional info:


can't upgrade system, no workaround.
Comment 1 Frank DiPrete 2008-03-09 13:51:11 EDT
[root@skipper ~]# lcpci -v
-bash: lcpci: command not found
[root@skipper ~]# lspci -v
00:00.0 Host bridge: Intel Corporation 82915G/P/GV/GL/PL/910GL Memory Controller
Hub (rev 04)
        Subsystem: Intel Corporation Unknown device 4556
        Flags: bus master, fast devsel, latency 0
        Capabilities: [e0] Vendor Specific Information

00:01.0 PCI bridge: Intel Corporation 82915G/P/GV/GL/PL/910GL PCI Express Root
Port (rev 04) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
        Memory behind bridge: ffa00000-ffafffff
        Prefetchable memory behind bridge: d3f00000-d3ffffff
        Capabilities: [88] #0d [0000]
        Capabilities: [80] Power Management version 2
        Capabilities: [90] Message Signalled Interrupts: 64bit- Queue=0/0 Enable-
        Capabilities: [a0] Express Root Port (Slot+) IRQ 0

00:02.0 VGA compatible controller: Intel Corporation 82915G/GV/910GL Integrated
Graphics Controller (rev 04) (prog-if 00 [VGA])
        Subsystem: Intel Corporation Unknown device 4556
        Flags: bus master, fast devsel, latency 0, IRQ 11
        Memory at ff480000 (32-bit, non-prefetchable) [size=512K]
        I/O ports at ec00 [size=8]
        Memory at d8000000 (32-bit, prefetchable) [size=128M]
        Memory at ff440000 (32-bit, non-prefetchable) [size=256K]
        Capabilities: [d0] Power Management version 2

00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI
Express Port 1 (rev 03) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=05, subordinate=05, sec-latency=0
        Memory behind bridge: ff600000-ff6fffff
        Prefetchable memory behind bridge: 00000000d3b00000-00000000d3b00000
        Capabilities: [40] Express Root Port (Slot+) IRQ 0
        Capabilities: [80] Message Signalled Interrupts: 64bit- Queue=0/0 Enable-
        Capabilities: [90] #0d [0000]
        Capabilities: [a0] Power Management version 2

00:1c.1 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI
Express Port 2 (rev 03) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=04, subordinate=04, sec-latency=0
        Memory behind bridge: ff700000-ff7fffff
        Prefetchable memory behind bridge: 00000000d3c00000-00000000d3c00000
        Capabilities: [40] Express Root Port (Slot+) IRQ 0
        Capabilities: [80] Message Signalled Interrupts: 64bit- Queue=0/0 Enable-
        Capabilities: [90] #0d [0000]
        Capabilities: [a0] Power Management version 2

00:1c.2 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI
Express Port 3 (rev 03) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=03, subordinate=03, sec-latency=0
        Memory behind bridge: ff800000-ff8fffff
        Prefetchable memory behind bridge: 00000000d3d00000-00000000d3d00000
        Capabilities: [40] Express Root Port (Slot+) IRQ 0
        Capabilities: [80] Message Signalled Interrupts: 64bit- Queue=0/0 Enable-
        Capabilities: [90] #0d [0000]
        Capabilities: [a0] Power Management version 2

00:1c.3 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI
Express Port 4 (rev 03) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=02, subordinate=02, sec-latency=0
        Memory behind bridge: ff900000-ff9fffff
        Prefetchable memory behind bridge: 00000000d3e00000-00000000d3e00000
        Capabilities: [40] Express Root Port (Slot+) IRQ 0
        Capabilities: [80] Message Signalled Interrupts: 64bit- Queue=0/0 Enable-
        Capabilities: [90] #0d [0000]
        Capabilities: [a0] Power Management version 2

00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #1 (rev 03) (prog-if 00 [UHCI])
        Subsystem: Intel Corporation Unknown device 4556
        Flags: bus master, medium devsel, latency 0, IRQ 20
        I/O ports at c800 [size=32]

00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #2 (rev 03) (prog-if 00 [UHCI])
        Subsystem: Intel Corporation Unknown device 4556
        Flags: bus master, medium devsel, latency 0, IRQ 19
        I/O ports at cc00 [size=32]

00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #3 (rev 03) (prog-if 00 [UHCI])
        Subsystem: Intel Corporation Unknown device 4556
        Flags: bus master, medium devsel, latency 0, IRQ 18
        I/O ports at d000 [size=32]

00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #4 (rev 03) (prog-if 00 [UHCI])
        Subsystem: Intel Corporation Unknown device 4556
        Flags: bus master, medium devsel, latency 0, IRQ 16
        I/O ports at d400 [size=32]

00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB2 EHCI Controller (rev 03) (prog-if 20 [EHCI])
        Subsystem: Intel Corporation Unknown device 4556
        Flags: bus master, medium devsel, latency 0, IRQ 20
        Memory at ff43fc00 (32-bit, non-prefetchable) [size=1K]
        Capabilities: [50] Power Management version 2
        Capabilities: [58] Debug port

00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev d3) (prog-if 01
[Subtractive decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=06, subordinate=06, sec-latency=32
        I/O behind bridge: 0000b000-0000bfff
        Memory behind bridge: ff500000-ff5fffff
        Prefetchable memory behind bridge: 00000000d4000000-00000000d7f00000
        Capabilities: [50] #0d [0000]

00:1f.0 ISA bridge: Intel Corporation 82801FB/FR (ICH6/ICH6R) LPC Interface
Bridge (rev 03)
        Subsystem: Intel Corporation Unknown device 4556
        Flags: bus master, medium devsel, latency 0

00:1f.1 IDE interface: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE
Controller (rev 03) (prog-if 8a [Master SecP PriP])
        Subsystem: Intel Corporation Unknown device 4556
        Flags: bus master, medium devsel, latency 0, IRQ 18
        I/O ports at 01f0 [size=8]
        I/O ports at 03f4 [size=1]
        I/O ports at 0170 [size=8]
        I/O ports at 0374 [size=1]
        I/O ports at ffa0 [size=16]

00:1f.2 IDE interface: Intel Corporation 82801FB/FW (ICH6/ICH6W) SATA Controller
(rev 03) (prog-if 8f [Master SecP SecO PriP PriO])
        Subsystem: Intel Corporation Unknown device 4556
        Flags: bus master, 66MHz, medium devsel, latency 0, IRQ 19
        I/O ports at e800 [size=8]
        I/O ports at e400 [size=4]
        I/O ports at e000 [size=8]
        I/O ports at dc00 [size=4]
        I/O ports at d800 [size=16]
        Capabilities: [70] Power Management version 2

00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus
Controller (rev 03)
        Subsystem: Intel Corporation Unknown device 4556
        Flags: medium devsel, IRQ 19
        I/O ports at c400 [size=32]

06:02.0 Multimedia video controller: Internext Compression Inc iTVC16 (CX23416)
MPEG-2 Encoder (rev 01)
        Subsystem: Hauppauge computer works Inc. WinTV PVR 250
        Flags: bus master, medium devsel, latency 64, IRQ 18
        Memory at d4000000 (32-bit, prefetchable) [size=64M]
        Capabilities: [44] Power Management version 2

06:08.0 Ethernet controller: Intel Corporation 82562ET/EZ/GT/GZ - PRO/100 VE
(LOM) Ethernet Controller (rev 01)
        Subsystem: Intel Corporation Unknown device 3061
        Flags: bus master, medium devsel, latency 32, IRQ 21
        Memory at ff500000 (32-bit, non-prefetchable) [size=4K]
        I/O ports at bc00 [size=64]
        Capabilities: [dc] Power Management version 2

Comment 2 Frank DiPrete 2008-03-09 13:52:56 EDT
boot device is sata

[root@skipper ~]# modinfo ata_piix
filename:       /lib/modules/2.6.22.14-72.fc6/kernel/drivers/ata/ata_piix.ko
version:        2.11
license:        GPL
description:    SCSI low-level driver for Intel PIIX/ICH ATA controllers
author:         Andre Hedrick, Alan Cox, Andrzej Krzysztofowicz, Jeff Garzik
srcversion:     385EF63E22C20071348F8B1
alias:          pci:v00008086d0000292Esv*sd*bc*sc*i*
alias:          pci:v00008086d0000292Dsv*sd*bc*sc*i*
alias:          pci:v00008086d00002928sv*sd*bc*sc*i*
alias:          pci:v00008086d00002926sv*sd*bc*sc*i*
alias:          pci:v00008086d00002921sv*sd*bc*sc*i*
alias:          pci:v00008086d00002920sv*sd*bc*sc*i*
alias:          pci:v00008086d00002828sv*sd*bc*sc*i*
alias:          pci:v00008086d00002825sv*sd*bc*sc*i*
alias:          pci:v00008086d00002820sv*sd*bc*sc*i*
alias:          pci:v00008086d00002680sv*sd*bc*sc*i*
alias:          pci:v00008086d000027C4sv*sd*bc*sc*i*
alias:          pci:v00008086d000027C0sv*sd*bc*sc*i*
alias:          pci:v00008086d00002653sv*sd*bc*sc*i*
alias:          pci:v00008086d00002652sv*sd*bc*sc*i*
alias:          pci:v00008086d00002651sv*sd*bc*sc*i*
alias:          pci:v00008086d000025B0sv*sd*bc*sc*i*
alias:          pci:v00008086d000025A3sv*sd*bc*sc*i*
alias:          pci:v00008086d000024DFsv*sd*bc*sc*i*
alias:          pci:v00008086d000024D1sv*sd*bc*sc*i*
alias:          pci:v00008086d00002850sv*sd*bc*sc*i*
alias:          pci:v00008086d0000269Esv*sd*bc*sc*i*
alias:          pci:v00008086d000027DFsv*sd*bc*sc*i*
alias:          pci:v00008086d0000266Fsv*sd*bc*sc*i*
alias:          pci:v00008086d000025A2sv*sd*bc*sc*i*
alias:          pci:v00008086d0000245Bsv*sd*bc*sc*i*
alias:          pci:v00008086d000024DBsv*sd*bc*sc*i*
alias:          pci:v00008086d000024CBsv*sd*bc*sc*i*
alias:          pci:v00008086d000024CAsv*sd*bc*sc*i*
alias:          pci:v00008086d0000248Bsv*sd*bc*sc*i*
alias:          pci:v00008086d0000248Asv*sd*bc*sc*i*
alias:          pci:v00008086d0000244Bsv*sd*bc*sc*i*
alias:          pci:v00008086d0000244Asv*sd*bc*sc*i*
alias:          pci:v00008086d00002421sv*sd*bc*sc*i*
alias:          pci:v00008086d00002411sv*sd*bc*sc*i*
alias:          pci:v00008086d000084CAsv*sd*bc*sc*i*
alias:          pci:v00008086d00007601sv*sd*bc*sc*i*
alias:          pci:v00008086d00007199sv*sd*bc*sc*i*
alias:          pci:v00008086d00007111sv*sd*bc*sc*i*
alias:          pci:v00008086d00007010sv*sd*bc*sc*i*
depends:        libata
vermagic:       2.6.22.14-72.fc6 SMP mod_unload 586 4KSTACKS 
Comment 3 Frank DiPrete 2008-03-09 14:32:48 EDT
Created attachment 297374 [details]
anaconda dump
Comment 4 Frank DiPrete 2008-03-09 14:46:50 EDT
I found the problem here:

http://forums.fedoraforum.org/showthread.php?t=157385

I found one blank line in /etc/modprobe.conf, removed it, wrote the file and
started again.

That was what threw anaconda into a failure state.
Comment 5 Chris Lumens 2008-03-10 09:29:45 EDT

*** This bug has been marked as a duplicate of 241991 ***

Note You need to log in before you can comment on or make changes to this bug.