Bug 436706 - Connection hangs shortly after useage
Connection hangs shortly after useage
Status: CLOSED DUPLICATE of bug 436577
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-09 14:15 EDT by Ken Kauffman
Modified: 2008-03-10 15:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-10 14:33:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ken Kauffman 2008-03-09 14:15:01 EDT
Description of problem:
Establishing a WPA connection.  With very little usage, the communication hangs
but NetworkManager shows the wireless as still active.


Version-Release number of selected component (if applicable):
Kernel 2.6.24.3-22.fc8 (koji)
Kernel 2.6.24.3-12.fc8
NetworkManager 1:0.7.0-0.6.7.svn.3370.fc8.x86_64
iwl4965-firmware 4.44.1.20-1



How reproducible: Always

Steps to Reproduce:
1. Connect to WPA access point (WPA-PSK)
2. Use web browser (after about 2-4 page changes, hangs)
3. dmesg
  
Actual results: (dmesg)
WARNING: at net/mac80211/rx.c:2073 __ieee80211_rx() (Not tainted)
Pid: 0, comm: swapper Not tainted 2.6.24.3-22.fc8 #1

Call Trace:
 <IRQ>  [<ffffffff88141fb8>] :mac80211:__ieee80211_rx+0x80/0x593
 [<ffffffff8816729b>] :iwl4965:iwl4965_rx_queue_restock+0xa4/0x129
 [<ffffffff8813382e>] :mac80211:ieee80211_tasklet_handler+0x5b/0x102
 [<ffffffff8103c4ea>] tasklet_action+0x53/0x9c
 [<ffffffff8103c3f9>] __do_softirq+0x55/0xc3
 [<ffffffff8100cf8c>] call_softirq+0x1c/0x28
 [<ffffffff8100e3c0>] do_softirq+0x2c/0x85
 [<ffffffff8103c35f>] irq_exit+0x3f/0x84
 [<ffffffff8100e67c>] do_IRQ+0x13e/0x162
 [<ffffffff8100c3a1>] ret_from_intr+0x0/0xa
 <EOI>  [<ffffffff811709af>] acpi_idle_enter_bm+0x265/0x2d1
 [<ffffffff811709a5>] acpi_idle_enter_bm+0x25b/0x2d1
 [<ffffffff811de94f>] cpuidle_idle_call+0x74/0xa9
 [<ffffffff811de8db>] cpuidle_idle_call+0x0/0xa9
 [<ffffffff8100b12d>] cpu_idle+0x94/0xbc
 [<ffffffff81437b06>] start_kernel+0x2d9/0x2e5
 [<ffffffff8143711d>] _sinittext+0x11d/0x124



Expected results:
Usability

Additional info:
Comment 1 Nicolas Chauvet (kwizart) 2008-03-09 16:37:20 EDT
Thx for your report.
But you should care of the right component
Re-Assigned to the right component (the kernel)

For cases like this, you can use the previous kernel (kernel-2.6.23.15-137.fc8)
Or test a newer kernel in updates-testing (when available).

Comment 2 Nicolas Chauvet (kwizart) 2008-03-09 16:39:03 EDT
oops, i didn't saw that your have tested a koji kernel 2.6.24.3-22.fc8...

Comment 3 Ken Kauffman 2008-03-09 22:18:49 EDT
It's not clear that this is a "kernel" issue.  If I do not load the
iwl4965-firmware package, then the card is not detected at all.  It almost
*appears* as though the packages is a separately maintained module.  I merely
offer this as a point of perspective and consideration and am not arguing with
your assertion.  
Comment 4 Wojciech Sluszniak 2008-03-10 09:08:26 EDT
I've got simmilar problem using Broadcom Corporation BCM4318 [AirForce One 54g]
802.11g Wireless LAN Controller (rev 02). Connection hangs after a while
(especially after a heavy load). Tried b43 & ndiswrapper. Only after switching
to previous kernel everything started to work great.

wojtekjs@gmail.com
Comment 5 John W. Linville 2008-03-10 14:33:09 EDT

*** This bug has been marked as a duplicate of 436577 ***
Comment 6 Ken Kauffman 2008-03-10 14:59:53 EDT
Please note that the situation described in this bug and steps to reproduce are
different than that of bug 436577.

Bug 436577 describes the inability to connect and obtain an IP.  I am able to
connect and obtain an IP, then it fails.
Comment 7 John W. Linville 2008-03-10 15:06:59 EDT
The backtraces are very similar.  If that bug closes and your problem 
persists, feel free to reopen this one...thanks!

Note You need to log in before you can comment on or make changes to this bug.