Bug 436719 - Logwatch doesn't show any usable sendmail section
Logwatch doesn't show any usable sendmail section
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: logwatch (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-09 18:01 EDT by Robert Scheck
Modified: 2013-01-27 09:01 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-30 10:19:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2008-03-09 18:01:36 EDT
Description of problem:
It looks to me as if logwatch wouldn't show any usable sendmail section as it 
does for postfix. AFAIK this was in past case - why not now any longer?

 --------------------- sendmail Begin ------------------------



 SMTP SESSION, MESSAGE, OR RECIPIENT ERRORS
 ------------------------------------------

 WARNING!!!!  Possible Attack:
    Attempt from [116.8.193.220] with:
       command=HELO/EHLO, count=3: 6 Time(s)
        Total:  6 Time(s)
 ---------------------- sendmail End -------------------------

Version-Release number of selected component (if applicable):
logwatch-7.3.6-20

How reproducible:
Everytime, run sendmail and logwatch. No or no real logwatch information.

Expected results:
Nice sendmail section such as postfix has and as it was case in the past.
Comment 1 Ivana Varekova 2008-03-10 04:53:27 EDT
It is better to report this kind of problem to upstream maintainers - they
should decide what is the best structure of sendmail output of logwatch. 
Please could you report this bug to upstream: http://www2.logwatch.org:81/ 
If there is any problem please write here a comment.
Comment 2 Robert Scheck 2008-03-10 05:16:48 EDT
Well...in the past there was more output in logwatch than above. This looks like
a regression to me. Is it possible, that sendmail in logwatch was maybe disabled 
or similar? Is it possible, that the default configuration of sendmail in logwatch
got maybe worse?
Comment 3 Robert Scheck 2008-03-10 05:17:18 EDT
I'm currently seeing this as downstream problem first, because I think, it's just
a default configuration issue or friends.
Comment 4 Robert Scheck 2008-03-10 19:29:03 EDT
Well, I had a more detailed look into this. What I'm maybe looking for is to set
"Detail = 3" in /usr/share/logwatch/default.conf/services/sendmail.conf - AFAIK
something like this was default in the past. But wait until changing defaults, I
will try to figure that out soon.
Comment 5 Ivana Varekova 2008-03-19 11:05:31 EDT
There is no sendmail script/ configuration patch in rawhide branch so for now
the current state is upstream solution. But I'm not sure I understand this bug
report absolutely - so if you don't agree with my resolution, please reopen this
bug and write me more detailed description please. 
Comment 6 Robert Scheck 2008-04-24 17:15:35 EDT
Can we apply the following patch or something better to logwatch so that if 
sendmail is in use, there's something in logwatch as well?

--- /usr/share/logwatch/default.conf/services/sendmail.conf
+++ /usr/share/logwatch/default.conf/services/sendmail.conf.rsc
@@ -34,7 +34,7 @@
 # logwatch Detail setting.
 #
 # Example:
-#Detail = 5
+Detail = 3
 #
 # The defined values of Detail are as follows:
 # Detail >= 0: Will print:";
Comment 7 Ivana Varekova 2008-04-30 10:19:27 EDT
Changed in logwatch-7.3.6-22.fc10.
Comment 8 Robert Scheck 2013-01-27 09:01:50 EST
logwatch-7.4.0-23.20130102svn127.fc19 reverts this behaviour - is this intended?

Note You need to log in before you can comment on or make changes to this bug.