Bug 436721 - Complete OS freeze bringing up wlan0 using rt73usb in 2.6.24
Complete OS freeze bringing up wlan0 using rt73usb in 2.6.24
Status: CLOSED DUPLICATE of bug 436627
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-09 18:18 EDT by Arnaud Van Remoortere
Modified: 2008-03-10 13:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-10 13:37:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arnaud Van Remoortere 2008-03-09 18:18:42 EDT
Description of problem: 

Bringing wlan0 up on 2.6.24.3-12.fc8 using rt73usb freezes the OS with no
possibility of recovery.


Version-Release number of selected component (if applicable):

This usb wireless adapter still works very well when I revert back to
kernel-2.6.23.15-137.fc8 which was the last 2.6.23 kernel I was able to update
to before 2.6.24


How reproducible: reproduces itself without fail


Steps to Reproduce:
1. insert USB wireless adapter
2. ifconfig wlan0 up
3.
  
Actual results: 

Complete OS freeze, not even possible to restart X using ctrl-alt-backspace


Expected results: wlan0 coming up


Additional info: 

lsmod: modules which load on 2.6.23 when I insert the USB adapter: 

aes                    31489  1 
arc4                    5953  2 
ecb                     6721  2 
blkcipher               9029  1 ecb
rt73usb                27201  0 
rt2x00usb              12865  1 rt73usb
rt2x00lib              21313  2 rt73usb,rt2x00usb
rfkill                  9425  1 rt2x00lib
input_polldev           7369  1 rt2x00lib
crc_itu_t               6081  1 rt2x00lib
mac80211              125137  2 rt2x00usb,rt2x00lib
cfg80211               19785  1 mac80211

lsmod: modules which load on 2.6.24 when I insert the USB adapter: 
  
arc4                    5825  2 
ecb                     6593  2 
blkcipher               9285  1 ecb
rt73usb                28097  0 
rt2x00usb              13121  1 rt73usb
rt2x00lib              30913  2 rt73usb,rt2x00usb
crc_itu_t               5953  1 rt2x00lib
rfkill                  9301  1 rt2x00lib
crc_ccitt               5953  1 rt2x00lib
input_polldev           7241  1 rt2x00lib
mac80211              161065  3 rt73usb,rt2x00usb,rt2x00lib
cfg80211               23113  2 rt2x00lib,mac80211

lsusb: Bus 002 Device 003: ID 050d:905c Belkin Components
Comment 1 John W. Linville 2008-03-10 13:37:11 EDT

*** This bug has been marked as a duplicate of 436627 ***

Note You need to log in before you can comment on or make changes to this bug.