Bug 436740 - kexec doesn't work on PS3
kexec doesn't work on PS3
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kexec-tools (Show other bugs)
8
ppc64 Linux
low Severity low
: ---
: ---
Assigned To: Neil Horman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-10 02:03 EDT by Kazunori Asayama
Modified: 2008-03-13 03:38 EDT (History)
0 users

See Also:
Fixed In Version: 1.102pre-6.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-13 03:38:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kazunori Asayama 2008-03-10 02:03:38 EDT
Description of problem:
  The kexec can't load a kernel onto PS3.

Version-Release number of selected component (if applicable):
  - kexec-tools-1.102pre-5.ppc
  - kexec-tools-1.102pre-5.ppc64

How reproducible:
  Every time.

Steps to Reproduce:
1. Run following command:

[root@localhost ~]# kexec -l --initrd=/boot/initrd-2.6.23.15-137.fc8.img
--append=root=/dev/VolGroup00/LogVol00 /boot/vmlinuz-2.6.23.15-137.fc8
  
Actual results:
- kexec-tools-1.102pre-5.ppc

  Cannot determine the file type of /boot/vmlinuz-2.6.23.15-137.fc8

- kexec-tools-1.102pre-5.ppc64

  get memory ranges:0
  Could not find a free area of memory of 775000 bytes...
  Base address: ffffffff is not page aligned

Expected results:

  get memory ranges:1
  Modified cmdline:root=/dev/VolGroup00/LogVol00 
  segment[0].mem:0x82b000 memsz:8560640
  segment[1].mem:0x1055000 memsz:16384
  segment[2].mem:0x1059000 memsz:4534272
  segment[3].mem:0x7bff000 memsz:4096

Additional info:

  - It looks like the following chage is needed to be applied:

http://git.kernel.org/?p=linux/kernel/git/horms/kexec-tools-testing.git;a=commit;h=02f4088ffded3d6f99a0c9f835727943d102b3df
Comment 1 Neil Horman 2008-03-10 09:20:05 EDT
sorry, theres a patch from kexec-tools-1.101 that was supposed to be upsream but
never got there, I'll have to re-add it shortly.  Thanks
Comment 2 Neil Horman 2008-03-10 15:07:21 EDT
nm, you're right, I am already carrying the patch that I needed.  I'll apply the
other patch you reference shortly
Comment 3 Neil Horman 2008-03-10 15:47:12 EDT
fixed in  -6.fc8.  Thanks!
Comment 4 Fedora Update System 2008-03-10 16:20:14 EDT
kexec-tools-1.102pre-6.fc8 has been submitted as an update for Fedora 8
Comment 5 Kazunori Asayama 2008-03-11 02:26:02 EDT
(In reply to comment #4)
> kexec-tools-1.102pre-6.fc8 has been submitted as an update for Fedora 8

The 64-bit build (kexec-tools-1.102pre-6.fc8.ppc64) works well. Thank you!

But the 32-bit build still complains:

  Cannot determine the file type of /boot/vmlinuz-2.6.23.15-137.fc8

It seems that the 32-bit kexec can't understand 64-bit kernel. Is it the
intended behavior?
Comment 6 Fedora Update System 2008-03-13 03:38:10 EDT
kexec-tools-1.102pre-6.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.