Bug 436750 - rexec username limit is 14 characters, not 16
rexec username limit is 14 characters, not 16
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rsh (Show other bugs)
4.6
All Linux
low Severity low
: rc
: ---
Assigned To: Adam Tkac
Ben Levenson
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-10 04:38 EDT by Andrew Ryan
Modified: 2013-04-30 19:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-15 06:54:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to correct the problem (546 bytes, patch)
2008-03-10 04:38 EDT, David Robinson
no flags Details | Diff

  None (edit)
Description David Robinson 2008-03-10 04:38:00 EDT
+++ This bug was initially created as a clone of Bug #436748 +++

Description of problem:
rexec username limit is 14 characters, not 16 as stated in rexecd(8). If a
username is longer than 14 characters then the user will not be able to login
via rexec.

Version-Release number of selected component (if applicable):
rsh-server-0.17-25.4

How reproducible:
100%

Steps to Reproduce:
1. useradd testtesttest1234
2. passwd testtesttest1234 # set to test
3. chkconfig rexec on
4. chkconfig xinetd on
5. service xinetd start
6. rexec -l testtesttest1234 -p test localhost date
  
Actual results:

$ rexec -l test -p test localhost date
Mon Mar 10 18:36:44 EST 2008
$ rexec -l testtesttest1234 -p test localhost date
rexec: Error in rexec system call,
rexec: (The following system error may itself be in error)
rexec: Connection reset by peer

Expected results:

$ rexec -l test -p test localhost date
Mon Mar 10 18:36:44 EST 2008
$ rexec -l testtesttest1234 -p test localhost date
Mon Mar 10 18:37:41 EST 2008

Additional info:
Patch to correct the problem is attached. It increases the size limit to 32
characters, which is the actual limit in rlogind.
Comment 1 David Robinson 2008-03-10 04:38:00 EDT
Created attachment 297410 [details]
patch to correct the problem
Comment 2 Adam Tkac 2008-03-27 11:57:03 EDT
Attached patch is not so good. See
https://bugzilla.redhat.com/show_bug.cgi?id=436748#c2 about improved one
Comment 4 RHEL Product and Program Management 2008-10-31 12:38:33 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".

Note You need to log in before you can comment on or make changes to this bug.