This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 436784 - System will not boot in MLS/Enforcing
System will not boot in MLS/Enforcing
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy-mls (Show other bugs)
rawhide
noarch Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-10 10:15 EDT by Joe Nall
Modified: 2008-03-11 17:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-11 17:33:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to launch bash with correct type. (526 bytes, patch)
2008-03-10 10:16 EDT, Joe Nall
no flags Details | Diff

  None (edit)
Description Joe Nall 2008-03-10 10:15:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-us) AppleWebKit/523.15.1 (KHTML, like Gecko) Version/3.0.4 Safari/523.15

Description of problem:
upstart is launching bash and shell scripts in the wrong type. Patch attached.

Version-Release number of selected component (if applicable):
selinux-policy-mls-3.3.1-12

How reproducible:
Always


Steps to Reproduce:
Boot in MLS/Enforcing

Actual Results:


Expected Results:


Additional info:
Comment 1 Joe Nall 2008-03-10 10:16:00 EDT
Created attachment 297438 [details]
Patch to launch bash with correct type.
Comment 2 Daniel Walsh 2008-03-10 16:08:49 EDT
Joe, Chris has vetoed this change,  I think we should leave the context in
init_t and then handle the avc's caused by this.
Comment 3 Joe Nall 2008-03-11 11:31:03 EDT
Do you want me to generate a new patch based on the init_upstart tunable work Chris did?
Comment 4 Joe Nall 2008-03-11 11:33:37 EDT
Chris added corecmd_shell_domtrans(init_t,initrc_t) to the policy but I needed corecmd_shell_entry_type(initrc_t) also to get things to work (see original patch).

Comment 5 Daniel Walsh 2008-03-11 17:33:36 EDT
Fixed in selinux-policy-3.3.1-14.fc9
Comment 6 Daniel Walsh 2008-03-11 17:33:57 EDT
Added your patch that is.

Note You need to log in before you can comment on or make changes to this bug.