Bug 43680 - iptables causing init failure
iptables causing init failure
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: iptables (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-06 00:23 EDT by David Patnode Jr.
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-06 00:24:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Patnode Jr. 2001-06-06 00:23:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
Custom install of RH7 on laptop. System booted fine; laptop later 
suspended, on resume system report lost interrupt for /dev/hda, kernel 
panic, etc. I powered off the system & back on again, and suddenly I get a 
message saying:

iptables v1.1.1: Unknown arg '-q'
Try 'iptables-h' or 'iptables --help' for more information.

Then everything fails, because this message keeps repeating for everything 
that tries to start.  Finally reaches point where it says "INIT: Id "1" 
respawning too fast: disabled for 5 minutes" (and that is repeated for Id 
1-6).

I've tried setting all the network options in /etc/sysctl to =0, I've 
tried commenting those lines out, I've tried renaming /sbin/iptables 
to /sbin/iptables.old. No success. I even get the error when booting into 
single user mode (ie lilo: linux single). Only then it's:

INIT: version 2.78 booting
iptables v1.1.1: Unknown arg '-r'
Try 'iptables-h' or 'iptables --help' for more information.

Any ideas on how to solve this?

How reproducible:
Always

Steps to Reproduce:
1.Reboot (happens every reboot, even single user mode)
2.
3.
	

Actual Results:  iptables v1.1.1: Unknown arg '-q'
Try iptables '-h' or 'iptables --help' for more information.
[FAILED] <-- (this is for every init script)

/etc/rc3.d/S99local: /etc/issue: Read-only file system
/etc/rc3.d/S99local: /etc/issue: Read-only file system
/etc/rc3.d/S99local: /etc/issue: Read-only file system
cp: cannot remove old like to '/etc/issue.net': Read only file system
/etc/rc3.d/S99local: /etc/issue: Read-only file system
INIT: Id "1" respawning too fast: disabled for 5 minutes
INIT: Id "2" respawning too fast: disabled for 5 minutes
INIT: Id "3" respawning too fast: disabled for 5 minutes
INIT: Id "4" respawning too fast: disabled for 5 minutes
INIT: Id "5" respawning too fast: disabled for 5 minutes
INIT: Id "6" respawning too fast: disabled for 5 minutes


Expected Results:  [SUCCESS] <- For all init's

Additional info:

Initial problem seemed to be related to hard-drive suspending and APM not 
correctly working. Simple change in apmd should fix this (according to 
apmd docs) but now cannot get past boot (can get to shell in single user 
mode, however, but then it is not running apm).
Comment 1 Bernhard Rosenkraenzer 2001-07-10 11:27:07 EDT
I can't reproduce this - looks like your /etc/inittab or crontab is severely 
misconfigured.

iptables is supposed to start once (at bootup), and does that just fine for 
everyone here.

The messages you're getting
INIT: Id "1" respawning too fast: disabled for 5 minutes
definitely don't have anything to do with iptables (this seems to indicate 
mingetty won't start).

My guess is your filesystem is severely corrupted.

Note You need to log in before you can comment on or make changes to this bug.