Bug 436800 - [RHEL5] Crash if malformed vcard is attached
[RHEL5] Crash if malformed vcard is attached
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: evolution (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Matthew Barnes
desktop-bugs@redhat.com
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-10 11:01 EDT by Christian Jung
Modified: 2008-05-21 11:19 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2008-0361
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:19:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 386157 None None None Never

  None (edit)
Description Christian Jung 2008-03-10 11:01:51 EDT
Description of problem:
If you receive an email with an attached vcard, evolution crashes if the vcard
is malformed.

Version-Release number of selected component (if applicable):
evolution-2.12.3-7.el5
evolution-data-server-1.12.3-5.el5
evolution-help-2.12.3-7.el5
evolution-connector-2.12.3-4.el5

How reproducible:
always

Steps to Reproduce:
1. send yourself an email with a malformed vcard
2. it seems to be important that the mime type of the vcard is set to x-vcard
(if it set to text, evo doesn't crash)
  
Actual results:
evolution crashes if you open the mail

Expected results:
evolution should not crash

Additional info:
A malformed vcard is available here:
https://bugs.launchpad.net/ubuntu/+source/evolution/+bug/199408

Evolution 2.8 does not crash with this kind of malformed vcards.

If someone is using the preview window, evolution always crashes on startup
since it tries to view the same mail again. You can disable the preview window
on the commandline:
evolution --disable-preview
Comment 5 Matthew Barnes 2008-03-14 15:29:06 EDT
This is http://bugzilla.gnome.org/show_bug.cgi?id=386157

Patch is available.  I guess it was never committed to the 2.12 branch.
Comment 7 RHEL Product and Program Management 2008-03-25 11:03:32 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 9 Matthew Barnes 2008-03-25 17:40:26 EDT
Fixed in evolution-data-server-1.12.3-6.el5.
Comment 13 errata-xmlrpc 2008-05-21 11:19:11 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0361.html

Note You need to log in before you can comment on or make changes to this bug.