Bug 436833 - SELinux is preventing ~/glnxa64/MATLAB from changing the access protection of memory on the heap.
SELinux is preventing ~/glnxa64/MATLAB from changing the access protection of...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy (Show other bugs)
5.1.z
x86_64 Linux
low Severity urgent
: rc
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-10 14:31 EDT by Phoebe
Modified: 2008-03-13 18:25 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-10 15:14:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
report from selinux (1.89 KB, text/plain)
2008-03-10 14:31 EDT, Phoebe
no flags Details
avc related from /var/log/audit.log (1.33 KB, text/plain)
2008-03-12 12:12 EDT, Phoebe
no flags Details

  None (edit)
Description Phoebe 2008-03-10 14:31:12 EDT
Description of problem:
Whenever trying to run matlab, this problem comes up. And the matlab calculation
result is false because of this problem.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.try to run any matlab program
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Phoebe 2008-03-10 14:31:12 EDT
Created attachment 297487 [details]
report from selinux
Comment 2 Daniel Walsh 2008-03-10 15:14:15 EDT
This is a bug in MATLAB.  So you have to turn on the boolean if you want to run
MATLAB until they fix it.

setsebool -P allow_execheap=1

This describes what execheap is.
http://people.redhat.com/~drepper/selinux-mem.html


Comment 3 Phoebe 2008-03-10 18:18:56 EDT
My allow_execheap is already set to 1, but still got the same error message.
$ cat allow_execheap 
1 1
$ cat allow_execmem 
1 1
$ cat allow_execmod 
0 0
$ cat allow_execstack 
1 1
Comment 4 Daniel Walsh 2008-03-11 17:37:49 EDT
Please attach the avc messages from /var/log/audit/audit.log

This might be a shared library that needs to be labeled textrel_shlib_t.

chcon -t textrel_shlib_t PATHTOLIB
Comment 5 Phoebe 2008-03-12 12:12:28 EDT
Created attachment 297800 [details]
avc related from /var/log/audit.log
Comment 6 Phoebe 2008-03-12 12:15:00 EDT
The following command doesn't work either.

# chcon -t textrel_shlib_t PATHTOLIB
chcon: PATHTOLIB: No such file or directory
Comment 7 Daniel Walsh 2008-03-13 18:25:22 EDT
PATHTOLIB was meant to be translated by you to an offending library.

The AVC messages you are now attaching are "granted"  So MATLIB is not being
deined anything.  The log file is just telling you, that you are doing something
that it does not like.

Note You need to log in before you can comment on or make changes to this bug.